You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2019-03-20 10:02:18

skazznj
Member
Registered: 2019-02-25
Posts: 24

[error] [http client] communication error: 500 Can't connect to myserv

Hi I created a vbs script to install the fusioninventory agent. When I run the script everything goes well and the agent installs correctly, but the computer does not go up in GLPI, so I will see in the fusioninventory.log file and I have this error :

[Wed Mar 20 08:56:53 2019][info] sending prolog request to server server0
[Wed Mar 20 08:56:53 2019][error] [http client] communication error: 500 Can't connect to myserv:444 (Bad file descriptor)
[Wed Mar 20 08:56:53 2019][error] No answer from server at myserv/plugins/fusioninventory/
[Wed Mar 20 08:56:53 2019][info] FusionInventory Agent memory usage: 3006464

I managed to fix this error when I do a manual installation by checking the "Disable SSL control (just use to debug)

Last edited by skazznj (2019-03-20 10:03:33)

Offline

#2 2019-04-05 10:22:52

francois-web
Guest
From: Paris
Registered: 2017-11-28
Posts: 2

Re: [error] [http client] communication error: 500 Can't connect to myserv

Hello.

I have the same problem. I've read some threads about without success.
I've increased the debug level of fusioninventory-agent.bat
Here's the log of the agent (a 2.4.3 x64 portable version running on Win10 Pro)

DEBUG: .../IO/Socket/SSL.pm:2823: new ctx 81855680
DEBUG: .../IO/Socket/SSL.pm:675: socket not yet connected
DEBUG: .../IO/Socket/SSL.pm:677: socket connected
DEBUG: .../IO/Socket/SSL.pm:700: ssl handshake not started
DEBUG: .../IO/Socket/SSL.pm:733: using SNI with hostname support.aede.fr
DEBUG: .../IO/Socket/SSL.pm:768: request OCSP stapling
DEBUG: .../IO/Socket/SSL.pm:789: set socket to non-blocking to enforce timeout=180
DEBUG: .../IO/Socket/SSL.pm:802: call Net::SSLeay::connect
DEBUG: .../IO/Socket/SSL.pm:805: done Net::SSLeay::connect -> -1
DEBUG: .../IO/Socket/SSL.pm:815: ssl handshake in progress
DEBUG: .../IO/Socket/SSL.pm:825: waiting for fd to become ready: SSL wants a read first
DEBUG: .../IO/Socket/SSL.pm:845: socket ready, retrying connect
DEBUG: .../IO/Socket/SSL.pm:802: call Net::SSLeay::connect
DEBUG: .../IO/Socket/SSL.pm:805: done Net::SSLeay::connect -> -1
DEBUG: .../IO/Socket/SSL.pm:815: ssl handshake in progress
DEBUG: .../IO/Socket/SSL.pm:825: waiting for fd to become ready: SSL wants a read first
DEBUG: .../IO/Socket/SSL.pm:845: socket ready, retrying connect
DEBUG: .../IO/Socket/SSL.pm:802: call Net::SSLeay::connect
DEBUG: .../IO/Socket/SSL.pm:2677: ok=0 [2] /C=BE/O=GlobalSign nv-sa/OU=Root CA/CN=GlobalSign Root CA/C=BE/O=GlobalSign nv-sa/OU=Root CA/CN=GlobalSign Root CA
DEBUG: .../IO/Socket/SSL.pm:805: done Net::SSLeay::connect -> -1
DEBUG: .../IO/Socket/SSL.pm:808: SSL connect attempt failed

DEBUG: .../IO/Socket/SSL.pm:808: local error: SSL connect attempt failed error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
DEBUG: .../IO/Socket/SSL.pm:811: fatal SSL error: SSL connect attempt failed error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
DEBUG: .../lib/Net/HTTPS.pm:67: ignoring less severe local error 'IO::Socket::IP configuration failed', keep 'SSL connect attempt failed error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed'
DEBUG: .../IO/Socket/SSL.pm:2845: free ctx 81855680 open=81855680
DEBUG: .../IO/Socket/SSL.pm:2849: free ctx 81855680 callback
DEBUG: .../IO/Socket/SSL.pm:2856: OK free ctx 81855680
[error] [http client] communication error: 500 Can't connect to support.domain.tld:443 (Bad file descriptor)
[error] No answer from server at https://support.domain.tld/

Looking further, i've found this thread : https://bugzilla.redhat.com/show_bug.cgi?id=1532250
So I decided to upgrade my Debian/Apache server to Jessie/2.4
I've enabled OCSP on my server. It is rated A+ on Ssllabs, openssl s_client tests are ok too...

I must confess that I don't really know where to look now. GLPI and Apache logs don't show anything.

Any ideas are welcome.

Maybe just a point to be clear :
What are the paths to put into the GPLI/Administration/Entities/Root Entity/FusionInventory and in the server parameter in agent.cfg ?
https://support.domain.tld/ or https://support.domain.tld/plugins/fusioninventory/ ?
And with a / at the end of the path or no ? (i've tried the different ways, but want to be sure)

Thanks in advance,

Francois

*************************

Bonjour,

Ce fil de discussion était en anglais, je l'ai continué en anglais. S'il faut créer un message spécifique en français, merci de me le dire.
Pour ceux qui préfèrent les VF :  j'ai le même problème que mentionné dans le message initial. La vérification SSL par l'agent ne fonctionne pas. Si je la désactive, la remontée d'inventaire dans GLPI fonctionne sans problème.
Le log de l'agent est présent au dessus (FI 2.4.3 x64 portable sur Win10 pro)
Côté serveur, j'ai fait les mises à jour vers Apache 2.4 pour disposer des derniers protocoles et de l'agrafage OCSP.
Les tests faits avec Ssllabs (A+) & consorts sont ok. Ceux réalisés avec openssl s_client aussi.
Les logs de GLPI et d'Apache ne renvoient rien de spécial.

Les idées sont les bienvenues.

Un dernier point, j'aimerais être certain
Quelle adresse doit être entrée dans GPLI/Administration/Entités/Entité racine/FusionInventory et dans le paramètre server du fichier agent.cfg
https://support.domaine.tld/ ou https://support.domaine.tld/plugins/fusioninventory/ ?
Et faut-il un / à la fin ou pas. J'ai essayé les différentes façons sans succès, mais je ne suis pas à l'abri d'un oubli.

Merci d'avance.

François

Offline

Board footer

Powered by FluxBB