You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2019-02-07 17:52:52

alex8276
Guest
Registered: 2013-12-16
Posts: 58

Création de Plugin Non conforme CSRF

Bonjour à tous,

je suis en train de tester la création de plugin en suivant la doc (https://glpi-developer-documentation.re … abase.html).
Je souhaiterais avoir des précisions concernant la conformité CSRF.

j'en suis a l'étape ou j'ai la possibilité d'installer mon plugin. Mon Hook créé une table. Cependant je ne peux pas l'activer car il n'est pas conforme CSRF ?
Que faut il faire pour qu'il le soit ? Sachant que je n'ai rien d'autre que mon fichier setup et Hook dans ce plugin qui ont du contenu. L'arborescence est basique
- monPlugin
  *front
  *inc
  *locale
  *tools
  +hook.php
  +LICENSE
  +monPlugin.xml
  +README.md
  +setup.php

* = Repertoire
+ = fichier
Merci d'avance et bonne fin de journée.


GLPI V9.3 + FusionInventory Version 9.1+1.0 - Serveur Debian 8

Offline

#2 2019-02-08 18:11:04

alex8276
Guest
Registered: 2013-12-16
Posts: 58

Re: Création de Plugin Non conforme CSRF

J'ai cherché toute la journée sans rien trouver de bien probant.
J'ai crééer les fichier php dasn front et inc.
L'installation et desinstallattion du plugin est ok mais pas possible d'activer car pas conforme CSRF.

J'ai créé le fichier local_define.php comme contenue define('GLPI_USE_CSRF_CHECK', 0); pour désactiver la vérification mais visiblement ce mécanisme ne fonctionne pas/plus.


GLPI V9.3 + FusionInventory Version 9.1+1.0 - Serveur Debian 8

Offline

#3 2019-02-12 12:57:35

alex8276
Guest
Registered: 2013-12-16
Posts: 58

Re: Création de Plugin Non conforme CSRF

Bon et bien c'était tout simplement une erreur de syntaxe...
mon plugin s'appelant "monPlugin" il fallait mettre $PLUGIN_HOOKS['csrf_compliant']['monPlugin'] = true; et non $PLUGIN_HOOKS['csrf_compliant']['monplugin'] = true;


GLPI V9.3 + FusionInventory Version 9.1+1.0 - Serveur Debian 8

Offline

Board footer

Powered by FluxBB