You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-05-22 21:56:22

hibernian
Guest
Registered: 2013-06-28
Posts: 2

GLPI and old server

Hello everyone

I inherited the old company server with Ubuntu 11.04 and GLPI 0.85.5. I would like to move GLPI to a new machine with Ubuntu 18.04.
And of course, update GLPI to the latest version.

Can I directly update GLPI 0.85.5 to version 9.2.3 or i need to install the updates sequentially? Should I use ubuntu 18.04 or maybe some earlier version?

What will be the best way to do it?

Thanks a lot in advance

Offline

#2 2018-05-24 10:31:45

soniyas9877
Guest
Registered: 2018-05-24
Posts: 3
Website

Re: GLPI and old server

there's no automated manner to update an existing plugin, because there would be too many cases to handle. but don’t
worry, technique is pretty easy wink
using empty functions is as simple as creating a few files:
• composer.json,
• .travis.yml,
• Robofile.personal home page,
• .gitignore.
in case you do now not have yet any composer or travis configuration document, you can simply reproduction the ones from empty plugin.

Offline

#3 2019-01-07 05:19:45

alexpslab
Member
From: LA, US
Registered: 2019-01-07
Posts: 3
Website

Re: GLPI and old server

Can I directly update GLPI 0.85.5 to version 9.2.3 or i need to install the updates sequentially? Should I use ubuntu 18.04 or maybe some earlier version?

Offline

#4 2019-01-07 16:53:10

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,509

Re: GLPI and old server

You can update GLPI from 0.85.5 to 9.2.3 in one time. But be careful of PHP value for max_execution_time and memory_limit


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

Board footer

Powered by FluxBB