You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-10-12 16:01:41

adbuckne
Member
From: NC, USA
Registered: 2018-10-12
Posts: 2

Windows Operating System not Updating (GLPI 9.2.4 & Fusion 9.2+2.0)

Setup:

GLPI Version 9.2.4
FusionInventory Plugin: 9.2+2.0
Fusion Inventory Agent: 2.4

Issue:

Updating a bunch of Windows 7 computers to Windows 10.  GLPI is still showing Windows 7 as the installed OS.  If I "Download inventory file" from the "Import information" tab on the computer object the OS is listed correctly.  If I look at the "Operating systems" tab it still shows the old OS information.

Offline

#2 2018-10-15 15:19:06

adbuckne
Member
From: NC, USA
Registered: 2018-10-12
Posts: 2

Re: Windows Operating System not Updating (GLPI 9.2.4 & Fusion 9.2+2.0)

In testing I updated GLPI (9.3.1) and Fusion (2.4.2) to the latest versions and the OS still doesn't change if I run a manual inventory update from a computer with the new Fusion Agent.  The correct OS name and version is in the downloaded inventory file.

Offline

#3 Yesterday 03:19:53

rjmontenegro
Guest
Registered: 2014-06-30
Posts: 12

Re: Windows Operating System not Updating (GLPI 9.2.4 & Fusion 9.2+2.0)

Same problem!

Offline

#4 Today 15:28:14

Ph1
Guest
From: Maine et loire
Registered: 2008-08-05
Posts: 151

Re: Windows Operating System not Updating (GLPI 9.2.4 & Fusion 9.2+2.0)

Hi,
I have the same problem (same version)!

In sql-errors.log, i have :

  *** MySQL query error:
  SQL: INSERT INTO `glpi_plugin_fusioninventory_dblocksoftwares`
                     SET `value`='1'
  Error: Duplicate entry '1' for key 'PRIMARY'
  Backtrace :
  ...ventory/inc/inventorycomputerlib.class.php:2675
  ...nventory/inc/inventorycomputerlib.class.php:821 PluginFusioninventoryInventoryComputerLib->importSoftware()
  ...ry/inc/inventorycomputerinventory.class.php:560 PluginFusioninventoryInventoryComputerLib->updateComputer()
  ...inventory/inc/inventoryruleimport.class.php:790 PluginFusioninventoryInventoryComputerInventory->rulepassed()
  inc/rule.class.php:1436                            PluginFusioninventoryInventoryRuleImport->executeActions()
  inc/rulecollection.class.php:1461                  Rule->process()
  ...ry/inc/inventorycomputerinventory.class.php:361 RuleCollection->processAllRules()
  ...ry/inc/inventorycomputerinventory.class.php:126 PluginFusioninventoryInventoryComputerInventory->sendCriteria()
  ...fusioninventory/inc/communication.class.php:235 PluginFusioninventoryInventoryComputerInventory->import()
  ...fusioninventory/inc/communication.class.php:463 PluginFusioninventoryCommunication->import()
  plugins/fusioninventory/front/communication.php:93 PluginFusioninventoryCommunication->handleOCSCommunication()
  plugins/fusioninventory/index.php:59               include_once()

Is it possible that i could be linked ?

adbuckne and rjmontenegro, do you have similar errors ?


Ph1 // Admin Systèmes & Réseaux
OS : Ubuntu 14.04
Authentification Kerberos // SSO Multi domaines AD
GLPI 9.2.3 // Fusion Inventory 9.2+2.0 (agent 2.4)

Offline

Board footer

Powered by FluxBB