You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-09-13 16:25:38

Diekel
Guest
From: Tours
Registered: 2018-09-13
Posts: 2

Problème de version de base de données (9.3.0 / 9.3.1)

Bonjour tous le monde !

Voilà je me tourne vers vous car j'ai un soucis assez étrange avec GLPI.

Dans le cadre de mon stage je dois monter un GLPI pour le service informatique et cela n'a jamais été un problème jusqu'à ce terrible 13 Septembre..

Pour vous résumer le soucis : J'ai ce matin même installer une Debian9 toute neuve sur un serveur qui ne contient qu'elle afin de pouvoir y travailler sans problème, toute l'installation se passe nickel, quelque petit soucis de proxy mais rien de bien méchant. J'installe donc mon LAMPs, tout s'installe sans problème et je met à l'installation de GLPI, après wgeter la 9.3, je l'installe, je donne les droits nécessaire, tous les modules sont au vert juste le warning du .htaccess, mais jusque la rien d'anormal tout est comme d'habitude.

Sauf que, à ce moment la il va charger dans le vide pendant et si jamais j'essaye d'allez sur la page principal de GLPI il me :

Votre version de la base de données n'est pas compatible avec la version des fichiers installés. Une mise à jour est nécessaire.

Ayant installer une même machine la veille dans l'AWS, je m'étonne de cette erreur et vais sur le site de GLPI et remarque l'apparition de 9.3.1 sortie hier. je me dit que sa peux avoir un lien, du coup je nettoie ma base MySQL (5.7) de la table GLPI, je recommence la manipulation et même erreur en 9.3

Pour palier à sa, je me dit qu'il y a peut être un conflit entre MySQL et GLPI, je me dis donc, essayons avec MariaDB, sachant que la version minimal de fonctionnement est la 10.0. Histoire que ce soit bien propre je réinstalle ENTIEREMENT ma debian9, pour être vraiment sur qu'il n'y ai pas le moindre fichier MySQL qui subsisterai dans un coin.

Une fois tout ce petit bazar terminé, je recommence ma manipulation et étant SUR que ma MariaDB est 10.1 mais il me dit le même message par rapport à la version, et si je décide de cliquer sur mettre à jour, je vous montre la capture d'écran tellement je ne comprends plus rien à ce qu'il lui arrive.

1536848652-glpi-erreur.png

Donc il me dit que la version de la base de données lui semble correct (et elle l'est d'après mes recherches dans la doc) mais elle n'est pas supportée...

Voilà je m'en remet donc à la communauté GLPI si jamais quelqu'un a une idée, je suis preneur smile

Last edited by Diekel (2018-09-13 16:26:39)

Offline

#2 2018-09-13 17:02:33

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 4,159

Re: Problème de version de base de données (9.3.0 / 9.3.1)

ou avez vous téléchargé l'archive ?
est ce la release officielle ?
ici : https://github.com/glpi-project/glpi/re … -9.3.1.tgz  ?


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+formcreator2.5.2 PHP7.0 Mariadb10
*GLPI 9.2.4(behaviours1.5.2+fusion9.2+1.0+applicatifs2.3.0+dashboard 0.8.9)hebergé sur serveur mutualisé.
*GLPI 9.3.1  en test (ubuntu 16.04 mariadb 10.2.4)

Offline

#3 2018-09-14 06:58:11

Diekel
Guest
From: Tours
Registered: 2018-09-13
Posts: 2

Re: Problème de version de base de données (9.3.0 / 9.3.1)

Bien sur j'ai pris l'archive du site smile

Ce qui me trouble le plus dans cette erreur c'est qu'une ligne à l'autre il me dit que tout va bien avec la BDD et la ligne d'après rien ne va plus..

Merci de prendre du temps pour mon problème smile

EDIT : Après une n-ènieme tentative j'ai fini par trouver la solution : Le processeur mettait trop de temps à écrire dans la base il suffisait de beaucoup de patience big_smile le problème était entre la chaise et la clavier, sujet résolut smile

Last edited by Diekel (2018-09-14 12:50:05)

Offline

Board footer

Powered by FluxBB