You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-07-03 11:22:33

Leunam
Guest
Registered: 2018-07-03
Posts: 3

Not conecting to LDAP after upgrade php to 5.6.35

Hi, We've updated php to 5.6 in order to update glpi, and since then we cannot connect with ldap cerver.

The error in the log is:

[2018-06-29 10:47:35] glpiphplog.ERROR: Toolbox::userErrorHandlerNormal() in /var/www/html/glpi/inc/toolbox.class.php line 657
  *** PHP Warning(2): ldap_connect(): Could not create session handle: Bad parameter to an ldap routine

Can anyone help us?

Best regards

Offline

#2 2018-07-03 12:00:31

MalcolmSio
Guest
Registered: 2016-02-02
Posts: 126

Re: Not conecting to LDAP after upgrade php to 5.6.35

Hi,

Did you install the extension ldap ?

Regards


GLPI 9.2.4
CentOS 7

Offline

#3 2018-07-03 12:10:53

Leunam
Guest
Registered: 2018-07-03
Posts: 3

Re: Not conecting to LDAP after upgrade php to 5.6.35

Yes we have.
We have other instalation with the same configuration but an older php version and works.
We downgraded php and works, but we need to upgrade it.

Thank you

Offline

#4 2018-07-03 12:12:47

MalcolmSio
Guest
Registered: 2016-02-02
Posts: 126

Re: Not conecting to LDAP after upgrade php to 5.6.35

You update to the extension ldap ?

What is your OS ?


GLPI 9.2.4
CentOS 7

Offline

#5 2018-07-03 12:59:31

Leunam
Guest
Registered: 2018-07-03
Posts: 3

Re: Not conecting to LDAP after upgrade php to 5.6.35

The extension is updated, the OS is RHEL 6.5

Thank you very much

Last edited by Leunam (2018-07-03 13:00:39)

Offline

#6 2018-07-06 15:34:54

Pandita
Guest
From: Poland
Registered: 2018-01-22
Posts: 10

Re: Not conecting to LDAP after upgrade php to 5.6.35

We have the similar problem here. GLPI fresh 9.3.0 install, php 7. LDAP config in GLPI is exactly the same.

Log:

[2018-07-06 15:31:47] glpiphplog.ERROR: Toolbox::userErrorHandlerNormal() in /var/www/glpi/inc/toolbox.class.php line 657                                                            │
  *** PHP Warning(2): ldap_search(): Search: Operations error                                                                                                                        │
  Backtrace :                                                                                                                                                                        │
  :                                                                                                                                                                                  │
  inc/authldap.class.php:2813                        ldap_search()                                                                                                                   │
  inc/auth.class.php:228                             AuthLDAP::searchUserDn()                                                                                                        │
  inc/authldap.class.php:2675                        Auth->connection_ldap()                                                                                                         │
  inc/authldap.class.php:2741                        AuthLDAP::ldapAuth()                                                                                                            │
  inc/auth.class.php:720                             AuthLDAP::tryLdapAuth()                                                                                                         │
  front/login.php:84                                 Auth->login()

Offline

#7 2018-09-11 22:10:07

KKAdmin
Guest
From: Germany
Registered: 2010-03-05
Posts: 844

Re: Not conecting to LDAP after upgrade php to 5.6.35

Do you use plugins ?
Deactivate all and test again.


You can mark this threat as [resolved] in subject of your threat. (This is only available edit of the first post.) It is good for users who help others to quickly see which post is still open.
##############################################
GLPI 9.2.3 /Ubuntu 16.04.4 LTS
Apache/2.4.18 (Ubuntu) - PHP 7.0.30-0ubuntu0.16.04.1 - MySQL 5.7.22-0ubuntu0.16.04.1

Offline

Board footer

Powered by FluxBB