You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-12-27 10:13:39

megastanou
Guest
Registered: 2011-08-22
Posts: 9

Problème de notification à l'administrateur de l'entitié

Bonjour,

Depuis la mise à jour en 9.2 mais aussi 9.2.1, la notification des nouveaux tickets à l'administrateur de l'entité ne fonctionne plus.
Notre GLPI a 4 entités : France, Hollande, Italie, Allemagne. Chaque entité a un "Courriel de l'administrateur" différent qui pointe vers une boite aux lettres de gestion du support par pays.
Nous envoyons une notification pour chaque nouveau ticket au demandeur et à l'administrateur de l'entité mais depuis la mise à jour uniquement le demandeur reçois la notification.

Lorsque que je créé un ticket en mode debug j'ai l'erreur suivante (qui semble être lié à mon problème) : PHP Notice: Undefined variable: admin_data in /var/www/html/inc/notificationtarget.class.php at line 661

Merci d'avance pour votre aide.

Offline

#2 2018-01-08 12:54:35

megastanou
Guest
Registered: 2011-08-22
Posts: 9

Re: Problème de notification à l'administrateur de l'entitié

Bonjour,

Je tenais à vous informer que j'ai solutionner mon problème :

dans le code de glpi depuis 9.2 il y a une erreur dans le fichier : /var/www/html/inc/notificationtarget.class.php line 661, il y a une erreur dans le nom de la variable testée dans le if() il faut remplacer $admin_data par $admins_data

/**
    * Add entity admin
    *
    * @return void
    */
   final public function addEntityAdmin() {
      $eventclass = $this->event;
      $admins_data = $eventclass::getEntityAdminsData($this->entity);

      if ($admin_data) {
         foreach ($admins_data as $admin_data) {
            if (!isset($admin_data['usertype'])) {
               $admin_data['usertype'] = self::getDefaultUserType();
            }
            $this->addToRecipientsList($admin_data);
         }
      }
   }


Cordialement

Last edited by megastanou (2018-01-08 12:56:35)

Offline

#3 2018-01-10 17:05:31

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,140

Re: Problème de notification à l'administrateur de l'entitié

Ticket ouvert sur la forge et corrigé : https://github.com/glpi-project/glpi/issues/3411


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#4 2018-03-12 22:53:10

jeanmoza
Guest
Registered: 2018-03-12
Posts: 11

Re: Problème de notification à l'administrateur de l'entitié

Bonjour,
je viens de tomber sur ce post. j'ai le même problème les emails partent pour l'admin général mais pas celui de l'entité.
Avez vous une idée ou une piste de recherche.
je suis en 9.2.2
Merci
J

Offline

#5 2018-03-13 15:35:41

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,140

Re: Problème de notification à l'administrateur de l'entitié

Le bug énoncé précédemment a été corrigé dans la version 9.2.2.
Vu que vous avez cette version, avez-vous des erreurs dans les logs de GLPI ?
En mode Debug, voyez-vous bien d'admin de l'entité en tant que destinataire des mails (onglet Debug d'un ticket) ?


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#6 2018-03-14 13:42:35

jeanmoza
Guest
Registered: 2018-03-12
Posts: 11

Re: Problème de notification à l'administrateur de l'entitié

Bonjour,
je ne trouve pas les informations que vous demandez, j'ai bien activé le debug mais dans la fenêtre de debug du bas, je ne sais pas ou cherché.
Concernant mon problème, le mail arrive bien mais avec l'adresse d'expéditeur. l'adresse de réponse est bien celle de l'entité par contre.C'est comme s'il ne prenait pas en compte le forçage d'adresse d'expédition dans l'entité
J

Offline

#7 2018-03-15 13:52:44

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,140

Re: Problème de notification à l'administrateur de l'entitié

Comme indiqué précédemmpent, une fois en mode Debug vous avez une nouvelle ouglet dans le ticket.
C'est cet onglet Debug qui trace des destinataires des mails


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#8 2018-03-15 20:17:20

jeanmoza
Guest
Registered: 2018-03-12
Posts: 11

Re: Problème de notification à l'administrateur de l'entitié

Bonjour,
vous parlez de ces informations ?
SQL REQUEST
AUTOLOAD
POST VARIABLE
GET VARIABLE
SESSION VARIABLE
SERVER VARIABLE

close debug
75 Queries took 0.003s

Queries
Time
Errors
1
SELECT *
FROM `glpi_plugins`
WHERE `state` = 1
0.000

2
SHOW COLUMNS
FROM `glpi_computers`
0.000

3
SHOW COLUMNS
FROM `glpi_monitors`
0.000

4
SHOW COLUMNS
FROM `glpi_softwares`
0.000

5
SHOW COLUMNS
FROM `glpi_networkequipments`
0.000

6
SHOW COLUMNS
FROM `glpi_peripherals`
0.000

Ce sont les informations en bas du navigateur. Mais je ne vois pas d'élément type adresse mail. je ne suis pas sur de regarder au bon endroit.
Dans tous les cas je n'ai pas d'onglet supplémentaire dans mon navigateur.
Merci pour votre patience
Jean

Offline

#9 2018-03-19 18:33:53

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,140

Re: Problème de notification à l'administrateur de l'entitié

Non je parle de l'onglet Debug qui est l'avant dernier onglet avant Tous dans un ticket


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#10 2018-03-19 21:32:14

jeanmoza
Guest
Registered: 2018-03-12
Posts: 11

Re: Problème de notification à l'administrateur de l'entitié

bonsoir,
je suis désolé mais je ne trouve pas les infos dont vous parlez. Lorsque j'active le mode debug j'ai deux boutons en bas de mon écran. Le premier est Ajax debug et l'autre et display only tab for debug. Quand je prends le premier j'ai des informations et j'ai le choix entre Sqlrequest, autoload .....et en dernier server variable. quand j'active le premier j'ai de façon furtive des infos qui s'affichent en bas de l'écran. J'ai testé avec d'autre navigateur sans plus de résultat.
j'ai le message d'erreur "STRICT_TRANS_TABLES,ERROR_FOR_DIVISION_BY_ZERO,NO_ZERO_DATE,NO_ZERO_IN_DATE,ONLY_FULL_GROUP_BY,NO_AUTO_CREATE_USER" sur la home quand je lance le debug.
Merci
J

Offline

#11 2018-03-20 17:13:47

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,140

Re: Problème de notification à l'administrateur de l'entitié

Je vous invite à lire attentivement ce que j'écris et ai écrit précédemment.

L'onglet Debug se trouve dans l'objet Ticket comme vous avez l'onglet Historique, traitement de ticket, document, suivi...


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#12 2018-03-20 22:19:24

jeanmoza
Guest
Registered: 2018-03-12
Posts: 11

Re: Problème de notification à l'administrateur de l'entitié

Bonjour,
Effectivement quand on lit c'est mieux. Je viens de trouver une partie mon problème avec le debug, c'était une adresse mal orthographiée, j'ai du passé au moins dix fois dessus avant de voir l'erreur.
Merci pour votre aide et votre patience, je continue mes tests.

C.

Offline

Board footer

Powered by FluxBB