You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2014-01-24 19:38:52

bebe21
Guest
Registered: 2014-01-07
Posts: 5

Generic Object : impossible de supprimer un gabarit

----------------------------------------------------------
- GLPI version 0.83.8
- Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1
- Version du client MySQL: mysqlnd 5.0.7-dev - 091210 - $Revision: 304625
- phpMyAdmin Version: 3.3.9
- Plugin Generic Object version 2.1.3
----------------------------------------------------------

Bonsoir,

Je vous contacte, car depuis ce matin, je n'arrive plus à supprimer de gabarit pour des objets créés avec le plugin Generic Object Management.

J'ai tellement cherché partout, (forum GLPI, google, doc du plugin) que je me sens un peu perdu, et je ne sais pas si je suis face à un bug ou si j'ai modifié un fichier PHP ou autre que je n'aurais pas du ...

Donc pour résumer, tout simplement je créé un objet "toto", et je tout de suite y ajouter un gabarit "test", que je souhaite tout de suite après supprimer.

Je clique sur le bouton "supprimer" à droite du gabarit, une requête se lance, et quand la page est rechargée je me retrouve de nouveau avec ce gabarit, nullement supprimé ! Je précise que je peux quand même réussir à supprimer le gabarit en allant chercher à la main dans la bade de donnée, mais ce n'est pas du tout utile pour l'utilisateur final.

Aucun message d'erreur ou autre...

Et cela fonctionne correctement avec les type d'objet classique, comme (test OK avec la catégorie Ordinateurs)

Merci beaucoup par avance pour votre aide ..

Bonne soirée, Cordialement, Ben.

Offline

#2 2014-01-24 23:41:01

bebe21
Guest
Registered: 2014-01-07
Posts: 5

Re: Generic Object : impossible de supprimer un gabarit

Bonsoir,

C'est assez rare, mais je m'auto-résout.

J'ai mis le mode "Debug" dans les préférences de mon comptes utilisateurs, et j'ai réessayé de supprimer un gabarit. Juste après avoir cliqué sur supprimé, la page se recharge, et l'espace d'un instant, on apperçoit ceci :

Undefined index: id in C:\xampp\htdocs\glpi\inc\commondbtm.class.php at line 1097

Sans perdre une seconde, direction le fichier "commondbtm.class.php" et là, que voi-je à la ligne 1097 ...

      if (!$this->getFromDB($input[$this->getIndexName()])) {
         return false;
      }

Qu'est-ce qu'il fout là ce ! au début du if ?? Bref, je le supprime, j'enregistre, et je retente la suppression de mon gabarit, et là merveille... ça fonctionne !

J'espère que ceci servira à certain débutant comme moi sous GLPI : Utilisez le mode DEBUG!!

Très bon week end, Ben.

EDIT :
Bon, apparemment le message d'érreur reste, même après avoir enlever le "!" dans le if, mais au moins mon gabarit se supprime. Si un developpeur passe par là, son idée sur le sujet serait la bienvenue !

Last edited by bebe21 (2014-01-24 23:44:55)

Offline

Board footer

Powered by FluxBB