You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2011-11-28 09:56:49

choco
Guest
Registered: 2011-11-28
Posts: 4

Problème lors de l'installation d'un plugin

Bonjour,
je viens vers vous, car lorsque j'installe un plugin et que je vais dans le menu plugin -> nomduplugin pour y acceder j'ai une erreur 500 à chaque fois.

Erreur HTTP 500 (Internal Server Error) : Une situation inattendue s'est produite tandis que le serveur tentait de traiter la demande.

Quelqu'un a t'il déjà rencontré ce problème ?

cordialement,
choco,

Offline

#2 2011-11-28 10:00:48

remi
GLPI-DEV
From: Champagne
Registered: 2007-04-28
Posts: 7,127
Website

Re: Problème lors de l'installation d'un plugin

Avec autant d'information, ça va être difficile de vous aider


Dév. Fedora 29 - PHP 5.6/7.0/7.1/7.2/7.3/7.4 - MariaDB 10.3 - GLPI master
Certifié ITILv3 - RPM pour Fedora, RHEL et CentOS sur https://blog.remirepo.net/

Offline

#3 2011-11-28 10:10:28

choco
Guest
Registered: 2011-11-28
Posts: 4

Re: Problème lors de l'installation d'un plugin

je vais préciser un peu,

j'ai installé le plugin fusion inventory pour glpi, dont j'ai transféré tous les fichiers dans le dossier plugin, puis je suis aller sur le site http://monip.com/glpi, j'ai été dans le menu configuration -> plugin.
J'ai tous bien installé (enfin je crois.. :s)
Puis je me suis rendu dans le menu plugin -> fusion Inventory et la j'ai eu une erreur 500.....

Offline

#4 2011-11-28 10:15:50

remi
GLPI-DEV
From: Champagne
Registered: 2007-04-28
Posts: 7,127
Website

Re: Problème lors de l'installation d'un plugin


Dév. Fedora 29 - PHP 5.6/7.0/7.1/7.2/7.3/7.4 - MariaDB 10.3 - GLPI master
Certifié ITILv3 - RPM pour Fedora, RHEL et CentOS sur https://blog.remirepo.net/

Offline

#5 2011-11-28 12:53:02

choco
Guest
Registered: 2011-11-28
Posts: 4

Re: Problème lors de l'installation d'un plugin

merci du lien smile

donc en fouinant dans les fichiers de log, je suis tomber sur ceci qui peut etre la cause du problème :

2011-11-24 17:39 [2@GPLI]
*** MySQL query error :
***
SQL:
CREATE TABLE `glpi_plugin_fusioninventory_agents` (
   `id` int(11) NOT NULL AUTO_INCREMENT,
   `entities_id` int(11) NOT NULL DEFAULT \'0\',
   `is_recursive` tinyint(1) NOT NULL DEFAULT \'1\',
   `name` varchar(255) DEFAULT NULL,
   `last_contact` datetime DEFAULT NULL,
   `version` varchar(255) DEFAULT NULL,
   `lock` tinyint(1) NOT NULL DEFAULT \'0\',
   `device_id` varchar(255) COLLATE utf8_unicode_ci DEFAULT NULL COMMENT \'XML <DEVICE_ID> TAG VALUE\',
   `items_id` int(11) NOT NULL DEFAULT \'0\',
   `itemtype` varchar(100) COLLATE utf8_unicode_ci DEFAULT NULL,
   `token` varchar(255) COLLATE utf8_unicode_ci DEFAULT NULL,
   `useragent` varchar(255) COLLATE utf8_unicode_ci DEFAULT NULL,
   PRIMARY KEY (`id`),
   KEY `name` (`name`),
   KEY `device_id` (`device_id`),
   KEY `item` (`itemtype`,`items_id`),
   KEY `items_id` (`items_id`),
) ENGINE=MyISAM  DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci
Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') ENGINE=MyISAM  DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci' at line 19

2011-11-24 17:39 [2@GPLI]
*** MySQL query error :
***
SQL:
CREATE TABLE IF NOT EXISTS `glpi_plugin_fusinvinventory_blacklists` (
  `id` int(11) NOT NULL AUTO_INCREMENT,
  `plugin_fusioninventory_criterium_id` int(11) NOT NULL DEFAULT \'0\',
  `value` varchar(255) DEFAULT NULL,
  PRIMARY KEY (`id`),
  KEY `plugin_fusioninventory_criterium_id` (`plugin_fusioninventory_criterium_id`),
) ENGINE=MyISAM  DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci
Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') ENGINE=MyISAM  DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci' at line 7


2011-11-24 17:39 [2@GPLI]
*** MySQL query error :
***
SQL:
INSERT INTO `glpi_plugin_fusinvinventory_blacklists` (`id`, `plugin_fusioninventory_criterium_id`, `value`) VALUES
(1, 3, \'50:50:54:50:30:30\'),
(2, 1, \'N/A\'),
(3, 1, \'(null string)\'),
(4, 1, \'INVALID\'),
(5, 1, \'SYS-1234567890\'),
(6, 1, \'SYS-9876543210\'),
(7, 1, \'SN-12345\'),
(8, 1, \'SN-1234567890\'),
(9, 1, \'1111111111\'),
(10, 1, \'1111111\'),
(11, 1, \'1\'),
(12, 1, \'0123456789\'),
(13, 1, \'12345\'),
(14, 1, \'123456\'),
(15, 1, \'1234567\'),
(16, 1, \'12345678\'),
(17, 1, \'123456789\'),
(18, 1, \'1234567890\'),
(19, 1, \'123456789000\'),
(20, 1, \'12345678901234567\'),
(21, 1, \'0000000000\'),
(22, 1, \'000000000\'),
(23, 1, \'00000000\'),
(24, 1, \'0000000\'),
(25, 1, \'0000000\'),
(26, 1, \'NNNNNNN\'),
(27, 1, \'xxxxxxxxxxx\'),
(28, 1, \'EVAL\'),
(29, 1, \'IATPASS\'),
(30, 1, \'none\'),
(31, 1, \'To Be Filled By O.E.M.\'),
(32, 1, \'Tulip Computers\'),
(33, 1, \'Serial Number xxxxxx\'),
(34, 1, \'SN-123456fvgv3i0b8o5n6n7k\'),
(35, 1, \'Unknow\'),
(36, 5, \'Unknow\'),
(37, 1, \'System Serial Number\'),
(38, 5, \'To Be Filled By O.E.M.\'),
(39, 5, \'*\'),
(40, 5, \'System Product Name\'),
(41, 5, \'Product Name\'),
(42, 5, \'System Name\'),
(43, 2, \'FFFFFFFF-FFFF-FFFF-FFFF-FFFFFFFFFFFF\'),
(44, 10, \'System manufacturer\'),

(45, 2, \'03000200-0400-0500-0006-000700080009\'),
(46, 2, \'6AB5B300-538D-1014-9FB5-B0684D007B53\'),
(47, 2, \'01010101-0101-0101-0101-010101010101\'),
(48, 3, \'20:41:53:59:4e:ff\'),
(49, 3, \'02:00:4e:43:50:49\'),
(50, 3, \'e2:e6:16:20:0a:35\'),
(51, 3, \'d2:0a:2d:a0:04:be\'),
(52, 3, \'00:a0:c6:00:00:00\'),
(53, 3, \'d2:6b:25:2f:2c:e7\'),
(54, 3, \'33:50:6f:45:30:30\'),
(55, 3, \'0a:00:27:00:00:00\'),
(56, 3, \'00:50:56:C0:00:01\'),
(57, 3, \'00:50:56:C0:00:08\'),
(58, 1, \'MB-1234567890\')
Error: Table 'glpidb.glpi_plugin_fusinvinventory_blacklists' doesn't exist

EDIT : voici le message complet quand je tente d'accèder à la page :

Erreur serveur
Le site Web a rencontré une erreur lors de l'extraction de http://172.28.12.8/gpli/public_html/plu … nventory/. Cela peut être dû à une opération de maintenance ou à une configuration incorrecte.
Voici quelques suggestions :
Actualisez cette page Web ultérieurement.
Erreur HTTP 500 (Internal Server Error) : Une situation inattendue s'est produite tandis que le serveur tentait de traiter la demande.

Last edited by choco (2011-11-28 13:08:27)

Offline

#6 2011-11-28 13:57:17

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,945

Re: Problème lors de l'installation d'un plugin

Je déplace dans la bonne section


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#7 2011-11-28 14:14:27

ddurieux
Plugins Dev
From: Monsols, France
Registered: 2005-06-17
Posts: 7,520

Re: Problème lors de l'installation d'un plugin

Quelle version de GLPI et des plugins FusionInventory ?


Support / dev / installation / configuration GLPI : dcs.glpi@dcsit-group.com
DCS : expert GLPI & FusionInventory / Développeur du plugin FusionInventory
IRC #glpi sur freenode.net

Offline

#8 2011-11-28 14:50:46

choco
Guest
Registered: 2011-11-28
Posts: 4

Re: Problème lors de l'installation d'un plugin

j'utilise la version 0.80.5 de gpli et la version 2.4.0 de fusionInventory

Offline

Board footer

Powered by FluxBB