You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2014-05-02 06:16:20

fai1633
Guest
Registered: 2013-11-26
Posts: 7

[Solved] Custom fields 1.6.0 Error

Dear All,

   I found that the error occur when i enable the custom fields plugin. anyone similar case? Please help. thank you.


GLPI Version: 0.84.5
Customfields version:  customfields-1.6.0, Date:04/16/2014 09:00 PM
download from: https://forge.indepnet.net/projects/customfields/files

Background:

         new user and several  existing user can not display all items in "Computers" which are super-admin profile(granted all permission)

Actions:

       Inventory - Computers

Result:

     Display a page without any items, however, when disable the plugin it can working normally.

Errors:

Unknown column 'glpi_plugin_customfields_computers_oem_information.oem_information' in 'field list'

Last edited by fai1633 (2014-05-02 11:58:59)

Offline

#2 2014-05-02 07:42:19

dethegeek
HELPER
From: France
Registered: 2013-09-03
Posts: 588
Website

Re: [Solved] Custom fields 1.6.0 Error

Hi

Can you identify some preference shared by the users having the issue ?

Last edited by dethegeek (2014-05-02 07:44:08)

Offline

#3 2014-05-02 08:11:43

fai1633
Guest
Registered: 2013-11-26
Posts: 7

Re: [Solved] Custom fields 1.6.0 Error

Hi dethegeek,

    There is a test account, which both is under super admin group.
     Super-admin profile
g9b4igbz.jpg

Last edited by fai1633 (2014-05-02 08:13:00)

Offline

#4 2014-05-02 08:12:28

fai1633
Guest
Registered: 2013-11-26
Posts: 7

Re: [Solved] Custom fields 1.6.0 Error

User Profile setting
vo8ickwl.jpg

Offline

#5 2014-05-02 08:13:37

fai1633
Guest
Registered: 2013-11-26
Posts: 7

Re: [Solved] Custom fields 1.6.0 Error

Debug Mode Errors
4d4s5iin.jpg

Offline

#6 2014-05-02 09:41:01

dethegeek
HELPER
From: France
Registered: 2013-09-03
Posts: 588
Website

Re: [Solved] Custom fields 1.6.0 Error

Hi

Your issue looks like the one I fixed yesterday, but is not exactly the same. CAn you try the latest revision in 1.6-bugfixes ?

Did you create a field for computers objects, then deleted it ?

Did the users having the issue set their preferences to show a field that does not longer exist ?

Last edited by dethegeek (2014-05-02 09:44:38)

Offline

#7 2014-05-02 10:46:19

fai1633
Guest
Registered: 2013-11-26
Posts: 7

Re: [Solved] Custom fields 1.6.0 Error

hi dethegeek,

   thank you for your reply. i had download the Revision 79(hook.php) and Revision 76(field.class.php)

1 . replace to GLPI plugin folder the original location.

2 . Reboot the CentOS Server


the problem still exist. same error as before.

------------------------------------------
Did you create a field for computers objects, then deleted it ?

Answer: Yes. i had created custom fields in "Computer" and then deleted it.

-------------------------------------------

Did the users having the issue set their preferences to show a field that does not longer exist ?

Answer: even create a new user with "super-admin" profile and first time log on, the items still can not display.
----------------------------------------------

Offline

#8 2014-05-02 11:21:38

dethegeek
HELPER
From: France
Registered: 2013-09-03
Posts: 588
Website

Re: [Solved] Custom fields 1.6.0 Error

I think the issue is due to the deletion of a field which is still used in the computer list. The view has probably been customized with this field and set globally.

A workaround which *may* work (I cannot test it right now) : try to re-create the deleted field, and check if the computer list works again. If it works again, you may remove the field from the global preference of the computer list, and finally delete the field.

I'll open a ticket to fix this.

Offline

#9 2014-05-02 11:43:31

fai1633
Guest
Registered: 2013-11-26
Posts: 7

Re: [Solved] Custom fields 1.6.0 Error

Thanks dethegeek. But I had deleted many fields, very hard to trace the deleted fields. Is that any way to reset the global preference of the computer list instead of re-create the deleted fields?

Offline

#10 2014-05-02 11:58:30

fai1633
Guest
Registered: 2013-11-26
Posts: 7

Re: [Solved] Custom fields 1.6.0 Error

Hi Dethegeek,

      i had try below link and works for me. anyway thank you for help!

try with this query:

delete from glpi_displaypreferences
where num between 5200 and 7699

Source:http://www.glpi-project.org/forum/viewt … =21639&p=8

Offline

#11 2014-05-02 20:23:26

dethegeek
HELPER
From: France
Registered: 2013-09-03
Posts: 588
Website

Re: [Solved] Custom fields 1.6.0 Error

Thank you for your feedback,

this will help me to find out how to fix the issue.

EDIT : created ticket : https://forge.indepnet.net/issues/4905

Last edited by dethegeek (2014-05-02 20:52:10)

Offline

Board footer

Powered by FluxBB