You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2006-05-24 15:14:26

tapadibal
Member
Registered: 2006-05-04
Posts: 123

Non d'une variable ..!

bonjour a tous je souhaiterais connaitre la variable qui contient le nom de l'utilisateur logger sur le poste pas celle de l'utilisateur logger sur glpi.
merci


OS WIN XP SP2
GLPI 0.68 - XAMPP 1.5.1 - OCS NG RC3-1
Longue vie à GLPI

Offline

#2 2006-05-24 15:37:27

VANB
Plugins Développeur
Registered: 2005-12-01
Posts: 354

Re: Non d'une variable ..!

Il y a plein d'infos la dessus dans http://glpi.indepnet.org/forum/viewtopic.php?id=1397


GLPI 0.71.5 / OS : Windows 2000 Server - SP4 / Décompactage : 7zip
Installation : Package Ocs NG 1.0 - Navigateurs : Internet Explorer 7
Serveur : Apache 2.2.3 / Base : mysql 5.0.27 / Langage : PHP 5.2.0 / PhpMyAdmin 2.9.1.1

Offline

#3 2006-05-24 15:50:57

tapadibal
Member
Registered: 2006-05-04
Posts: 123

Re: Non d'une variable ..!

merci, mais je me suis mal expliqué.
en fait je voudrais que les utilisateurs "post only" se log tous avec le meme login.
et qu'une fois logger s'ils choisissent "ordinateur" leur nom de log sur la machine apparaisse pour une recherche plus facile de son ordinateur.


OS WIN XP SP2
GLPI 0.68 - XAMPP 1.5.1 - OCS NG RC3-1
Longue vie à GLPI

Offline

#4 2006-05-24 16:51:15

tapadibal
Member
Registered: 2006-05-04
Posts: 123

Re: Non d'une variable ..!

personne tant pis ..!
pourtant j'ai essayer de m'aider de se post http://glpi.indepnet.org/forum/viewtopic.php?id=2935
mais il retourne le log de glpi est non pas celui de la session ouverte sur le pc.
voila ce qui a fait l'objet de ma premiére question.merci


OS WIN XP SP2
GLPI 0.68 - XAMPP 1.5.1 - OCS NG RC3-1
Longue vie à GLPI

Offline

#5 2006-05-24 19:15:58

VANB
Plugins Développeur
Registered: 2005-12-01
Posts: 354

Re: Non d'une variable ..!

Lisez mieux le post :
La solution pour récupérer l'utilisateur qui a ouvert la session sur le PC est d'utiliser le module mod_auth_sspi et cela est décrit en détail dans le post.


GLPI 0.71.5 / OS : Windows 2000 Server - SP4 / Décompactage : 7zip
Installation : Package Ocs NG 1.0 - Navigateurs : Internet Explorer 7
Serveur : Apache 2.2.3 / Base : mysql 5.0.27 / Langage : PHP 5.2.0 / PhpMyAdmin 2.9.1.1

Offline

#6 2006-05-25 19:04:30

emgenet
Member
From: Charleville-Mézières - 08
Registered: 2006-02-10
Posts: 770
Website

Re: Non d'une variable ..!

VANB, si j'ai bien lu, le mod_auth_sspi ne marche que si le serveur glpi est sous windows, et non linux ?


GLPI: 0.72.3 et OCS 1.0.1
Plateforme: Linux Debian Lenny (5.0) Navigateur: IE7-8 & FrFx2-3
PHP: 5.2.6;  MySQL: 5.0.51;  Apache: 2.2.9;

Offline

#7 2006-05-25 19:16:46

VANB
Plugins Développeur
Registered: 2005-12-01
Posts: 354

Re: Non d'une variable ..!

Oui, c'est bien ça emgenet. Je ne crois pas qu'il y ait d'équivalent sous linux.


GLPI 0.71.5 / OS : Windows 2000 Server - SP4 / Décompactage : 7zip
Installation : Package Ocs NG 1.0 - Navigateurs : Internet Explorer 7
Serveur : Apache 2.2.3 / Base : mysql 5.0.27 / Langage : PHP 5.2.0 / PhpMyAdmin 2.9.1.1

Offline

#8 2006-05-29 09:45:12

tapadibal
Member
Registered: 2006-05-04
Posts: 123

Re: Non d'une variable ..!

j'ai bien relu le post mais je ne vois pas très bien la marche a suivre . le tout me semble confus . de plus je ne suis pas sur active directory ,est-ce que ca marche aussi??

desolé pour toute ces questions...

merci


OS WIN XP SP2
GLPI 0.68 - XAMPP 1.5.1 - OCS NG RC3-1
Longue vie à GLPI

Offline

#9 2006-05-29 20:12:23

VANB
Plugins Développeur
Registered: 2005-12-01
Posts: 354

Re: Non d'une variable ..!

Encore faut-il regarder le bon post : j'avais écrit http://glpi-project.org/forum/viewtopic.php?id=1397 (et non 2935).

Bon, je suis dans un bon jour et j'essaye d'expliquer plus simplement et en condensé.

En php sous windows, il est possible de récupérer le nom de l'utilisateur connecté au pc dans la variable _SERVER["AUTH_USER"] (il y en a d'autres qui donnent la même information : voir phpinfo()).

Cela marche nativement sous IIS à condition que le site ne soit pas configuré en accès anonyme.

Par contre sous Apache, il faut activer le module mod_auth_sspi en décommentant la ligne ci-après du fichier httpd.conf (dans apache/conf) :

LoadModule sspi_auth_module modules/mod_auth_sspi.so

De plus, il faut configurer le module par les lignes ci-après ajoutées dans le même httpd.conf

#glpi configuration
<Directory "C:/OCSinventoryNG/xampp/htdocs/glpi>
    Options None
    Order allow,deny
    Allow from all
    
    AuthName "Accès restreint"
    AuthType SSPI
    SSPIAuth On
    SSPIAuthoritative On
    SSPIOfferBasic On
    require valid-user
</Directory>

Penser à redémarrer Apache !

Après, il ne reste plus qu'à écrire le code pour obtenir le comportement que vous souhaitez wink.

Last edited by VANB (2006-05-31 16:39:08)


GLPI 0.71.5 / OS : Windows 2000 Server - SP4 / Décompactage : 7zip
Installation : Package Ocs NG 1.0 - Navigateurs : Internet Explorer 7
Serveur : Apache 2.2.3 / Base : mysql 5.0.27 / Langage : PHP 5.2.0 / PhpMyAdmin 2.9.1.1

Offline

#10 2006-05-31 10:04:59

tapadibal
Member
Registered: 2006-05-04
Posts: 123

Re: Non d'une variable ..!

merci beaucoup pour votre aide .
dans le fichier php.ini il n'y a pas la ligne loadmodule.
elle se trouve dans le fichier httpd.conf (apache\conf)

merci a tous


OS WIN XP SP2
GLPI 0.68 - XAMPP 1.5.1 - OCS NG RC3-1
Longue vie à GLPI

Offline

#11 2006-05-31 12:58:26

VANB
Plugins Développeur
Registered: 2005-12-01
Posts: 354

Re: Non d'une variable ..!

Oui c'est vrai, désolé pour cette étourderie. Je corrige le post.

Merci de l'avoir signalée

Last edited by VANB (2006-05-31 12:58:54)


GLPI 0.71.5 / OS : Windows 2000 Server - SP4 / Décompactage : 7zip
Installation : Package Ocs NG 1.0 - Navigateurs : Internet Explorer 7
Serveur : Apache 2.2.3 / Base : mysql 5.0.27 / Langage : PHP 5.2.0 / PhpMyAdmin 2.9.1.1

Offline

#12 2006-05-31 15:14:19

tapadibal
Member
Registered: 2006-05-04
Posts: 123

Re: Non d'une variable ..!

j'ai bien decommenter la ligne et j'ai bien copier à la fin du fichier mais je narrive pas recuperer la variable _SERVER["AUTH_USER"]


OS WIN XP SP2
GLPI 0.68 - XAMPP 1.5.1 - OCS NG RC3-1
Longue vie à GLPI

Offline

#13 2006-05-31 15:19:46

VANB
Plugins Développeur
Registered: 2005-12-01
Posts: 354

Re: Non d'une variable ..!

Avez-vous adapté la ligne <Directory "C:/OCSinventoryNG/xampp/htdocs/glpi> à votre configuration ?


GLPI 0.71.5 / OS : Windows 2000 Server - SP4 / Décompactage : 7zip
Installation : Package Ocs NG 1.0 - Navigateurs : Internet Explorer 7
Serveur : Apache 2.2.3 / Base : mysql 5.0.27 / Langage : PHP 5.2.0 / PhpMyAdmin 2.9.1.1

Offline

#14 2006-05-31 15:25:04

tapadibal
Member
Registered: 2006-05-04
Posts: 123

Re: Non d'une variable ..!

oui j'ai bien mis le chemin qui correspond au dossier de glpi


OS WIN XP SP2
GLPI 0.68 - XAMPP 1.5.1 - OCS NG RC3-1
Longue vie à GLPI

Offline

#15 2006-05-31 16:37:22

VANB
Plugins Développeur
Registered: 2005-12-01
Posts: 354

Re: Non d'une variable ..!

Avez-vous redémarré apache (je le rajoute dans le post) ?

Last edited by VANB (2006-05-31 16:38:18)


GLPI 0.71.5 / OS : Windows 2000 Server - SP4 / Décompactage : 7zip
Installation : Package Ocs NG 1.0 - Navigateurs : Internet Explorer 7
Serveur : Apache 2.2.3 / Base : mysql 5.0.27 / Langage : PHP 5.2.0 / PhpMyAdmin 2.9.1.1

Offline

#16 2006-05-31 16:45:09

tapadibal
Member
Registered: 2006-05-04
Posts: 123

Re: Non d'une variable ..!

oui j'ai bien redémarer apache .
le probleme venait de l'adresse OCS INVENTORY NG qui est ecrit tout attacher dans le code , est ayant fait un copier coller ca ne marchais pas car il faut séparer dans le nom du chemin voila .
et sinon ca marche merci a toi VANB de m'avoir aider .


OS WIN XP SP2
GLPI 0.68 - XAMPP 1.5.1 - OCS NG RC3-1
Longue vie à GLPI

Offline

#17 2006-05-31 19:23:45

VANB
Plugins Développeur
Registered: 2005-12-01
Posts: 354

Re: Non d'une variable ..!

Serviteur wink


GLPI 0.71.5 / OS : Windows 2000 Server - SP4 / Décompactage : 7zip
Installation : Package Ocs NG 1.0 - Navigateurs : Internet Explorer 7
Serveur : Apache 2.2.3 / Base : mysql 5.0.27 / Langage : PHP 5.2.0 / PhpMyAdmin 2.9.1.1

Offline

Board footer

Powered by FluxBB