You are not logged in.


 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2019-11-07 00:26:53

Registered: 2013-09-27
Posts: 2

dependencies problem on glpi 9.4 install

Hi all,

i've a little problem of dependencies when i try to install glpi 9.4 on my centOS 8 virtual machine.

i trying to install glpi with this (i'm login with super admin account) :

dnf module --enablerepo=remi install -y glpi:9.4

but it return 1 error :

problem package glpi- requires php-composer(fedora/autoloader), but none of the providers can be installed

- cannot install the best candidate for the job
- package php-fedora-autoloader-1.0.0-5.el8.remi.noarch is excluded.

i take this :


it success, but nothing happen when i retry glpi install, same error.

my skill on centos is very limited and i don't understand what i need to do....any suggestion ?

thanks for any helps


#2 2019-11-07 04:51:13

From: Indonesia
Registered: 2011-05-20
Posts: 129

Re: dependencies problem on glpi 9.4 install

I think if on ubuntu will look like this

sudo apt-get install php-composer

GLPI 9.4.5
Installation mode: RPM on centos 7


#3 2019-11-07 10:11:03

Registered: 2013-09-27
Posts: 2

Re: dependencies problem on glpi 9.4 install


My install is in progress, after a good night my research was most efficient ^^.

So, i find a good instruction install on git.remirepo :


but i had some error install on php module install section (dependecies again....but other).

So i find a good solution with instruction glpi install on centos 6, but i translate it on centos 8, i saved the depot with this command :

wget https****:*****//
wget http*****:*****//
rpm -Uvh remi-release-8.rpm epel-release-latest-6.noarch.rpm

after i reset my php with this :

dnf module reset -y  php

reswitch php version on remi 7.3 with this :

dnf module install -y  php:remi-7.3

activate php and apache module with this after :

systemctl enable --now php-fpm
systemctl enable --now httpd

and finally installed glpi 9.4 version, and it's work ..

i hope my problem can be help some person wink.

have a nice day !


Board footer

Powered by FluxBB