You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2019-06-19 08:47:00

amerlet
Member
Registered: 2019-06-19
Posts: 1

BUG sans paramètre noauto=1 en 9.4.2

Bonjour,

depuis la mise à jour en 9.4.2, impossible de me connecter à GLPI sans le paramètre noauto=1 dans l'url

voici l'erreur dans les log :

[Wed Jun 19 08:44:59.607754 2019] [php7:error] [pid 11215] [client 192.168.30.201:62332] PHP Fatal error:  Uncaught ArgumentCountError: Too few arguments to function Auth::redirectIfAuthenticated(), 0 passed in /var/www/html/glpi/index.php on line 78 and at least 1 expected in /var/www/html/glpi/inc/auth.class.php:1209\nStack trace:\n#0 /var/www/html/glpi/index.php(78): Auth::redirectIfAuthenticated()\n#1 {main}\n  thrown in /var/www/html/glpi/inc/auth.class.php on line 1209

Je pense qu'il manque un paramètre lors de l'appel de la fonction Auth::redirectIfAuthenticated() dans l'index.php

Si un expert du projet pouvais me confirmer cela ?

Merci.

Offline

#2 2019-06-19 16:44:17

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,053

Re: BUG sans paramètre noauto=1 en 9.4.2

Pouvez-vous transmettre l'erreur complète ? (glpi/files/_logs/php-error.log)


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#3 2019-06-25 18:15:12

mecmav
Member
From: Brasil
Registered: 2019-03-22
Posts: 41

Re: BUG sans paramètre noauto=1 en 9.4.2

I'm having the same problem. When I try open in a new tab by the hostname, getting error 500. That Works normally by opening the login screen IP/index.php?noAUTO=1. How fix this? This started happening after installed Plugin Mod

Offline

Board footer

Powered by FluxBB