You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-11-16 16:15:11

sukky
Member
Registered: 2018-11-16
Posts: 3

Installation du plugins impossible : erreur BDD

Bonjour,

J'ai un problème lors de l'installation de mon plugins FusionInventory. J'ai réussi à comprendre que l'erreur venait de MySQL mais après de multiple tentatives je ne parviens pas à trouver qu'est ce qui les provoquent.
Voici les erreurs :

PHP Notice: mysqli::query(): send of 8192 bytes failed with errno=104 Connection reset by peer in /var/www/01-glpi/inc/dbmysql.class.php at line 170
PHP Warning: mysqli::query(): MySQL server has gone away in /var/www/01-glpi/inc/dbmysql.class.php at line 170
PHP Warning: mysqli::query(): Error reading result set's header in /var/www/01-glpi/inc/dbmysql.class.php at line 170

Fatal error: Uncaught Error: Call to a member function bind_param() on boolean in /var/www/01-glpi/plugins/fusioninventory/install/update.php:680 Stack trace: #0 /var/www/01-glpi/plugins/fusioninventory/hook.php(849): pluginFusioninventoryUpdate('1.1.0', 'Migration') #1 /var/www/01-glpi/inc/plugin.class.php(707): plugin_fusioninventory_install() #2 /var/www/01-glpi/front/plugin.form.php(47): Plugin->install('8') #3 {main} thrown in /var/www/01-glpi/plugins/fusioninventory/install/update.php on line 680


J'ai déjà essayé de modifier le parametre "max_allowed_packet" et mon "wait_timeout" est assez grand.

Mon GLPI est 9.3.2, FusionInventory : 9.3+1.2; MySQL 5.7.24

Merci d'avance pour votre aide.

Offline

#2 2018-12-03 16:56:27

Green_Kraken
Guest
Registered: 2018-02-06
Posts: 8

Re: Installation du plugins impossible : erreur BDD

Le problème vient de ta version de Mysql, tu dois utiliser la version 7.0.
Je vois même pas comment tu as pu le démarrer ton Glpi.
Bref, je te conseillerai une nouvelle machine avec un mysql 7.0 et glpi 9.3.2.

Offline

#3 2018-12-10 12:04:37

sukky
Member
Registered: 2018-11-16
Posts: 3

Re: Installation du plugins impossible : erreur BDD

Bonjour,

La version minimale de MySQL pour GLPI est la 5.6. C'est pour cela qu'il fonctionne. Je n'ai jamais trouvé de pré-requis de version pour installer FusionInventory, je ne pouvais donc pas me douter que le problème vienne de là. D'ailleurs qu'est ce qui vous fait dire que le problème vient de la version ?

D'avance merci.

Cordialement,

Offline

#4 2018-12-10 14:45:06

sukky
Member
Registered: 2018-11-16
Posts: 3

Re: Installation du plugins impossible : erreur BDD

Et pour information : MySQL 7 n'existe plus, il s'agit de MySQL8. D'autant plus, MySQL 5.7 reste grandement utilisé.

Offline

Board footer

Powered by FluxBB