You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-06-12 21:36:22

KKAdmin
Guest
From: Germany
Registered: 2010-03-05
Posts: 796

SQL strict mode is not fully enabled / Ubuntu 18.10 MariaDB 10.1.29

I got this message in glpi:

SQL strict mode is not fully enabled, recommended for development: STRICT_TRANS_TABLES,ERROR_FOR_DIVISION_BY_ZERO,NO_ZERO_DATE,NO_ZERO_IN_DATE,ONLY_FULL_GROUP_BY,NO_AUTO_CREATE_USER
297 tables not migrated to InnoDB engine.

MariaDB [(none)]> show variables like 'sql_mode'
    -> ;
+---------------+--------------------------------------------------------------------------------------------------------------------+
| Variable_name | Value                                                                                                              |
+---------------+--------------------------------------------------------------------------------------------------------------------+
| sql_mode      | ONLY_FULL_GROUP_BY,STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER |
+---------------+--------------------------------------------------------------------------------------------------------------------+
1 row in set (0.00 sec)

MariaDB [(none)]> use glpidb
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
MariaDB [glpidb]> show variables like 'sql_mode';
+---------------+--------------------------------------------------------------------------------------------------------------------+
| Variable_name | Value                                                                                                              |
+---------------+--------------------------------------------------------------------------------------------------------------------+
| sql_mode      | ONLY_FULL_GROUP_BY,STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER |
+---------------+--------------------------------------------------------------------------------------------------------------------+
1 row in set (0.00 sec)

MariaDB [glpidb]>

I can't solve this problem with google wink https://tic.gal/en/fix-mysql-strict-mod … bled-glpi/


You can mark this threat as [resolved] in subject of your threat. (This is only available edit of the first post.) It is good for users who help others to quickly see which post is still open.
##############################################
GLPI 9.2.3 /Ubuntu 16.04.4 LTS
Apache/2.4.18 (Ubuntu) - PHP 7.0.30-0ubuntu0.16.04.1 - MySQL 5.7.22-0ubuntu0.16.04.1

Offline

#2 2018-06-17 05:54:49

trasher
Administrator
From: Montpellier
Registered: 2017-10-20
Posts: 32
Website

Re: SQL strict mode is not fully enabled / Ubuntu 18.10 MariaDB 10.1.29

You should not enable strict mode; this may cause issues right now. This is a pure development message; it appears on RC as a side effect.

Offline

Board footer

Powered by FluxBB