You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-05-30 22:23:43

dparker
Guest
Registered: 2016-05-17
Posts: 8

How to fix "SQL strict mode is not fully enabled..."?

Hello, Has anyone ran into this and was able to fix it? I've tried adding the line into the /etc/mysql/my.cnf file, restarting mysql, but no luck.

"SQL strict mode is not fully enabled, recommended for development: STRICT_TRANS_TABLES,ERROR_FOR_DIVISION_BY_ZERO,NO_ZERO_DATE,NO_ZERO_IN_DATE,ONLY_FULL_GROUP_BY,NO_AUTO_CREATE_USER"
glpi-error-sql-strict_zpsrkzhyudn.png


# mysql -psecret -e "select @@sql_mode"
+--------------------------------------------------------------------------------------------------------------------+
| @@sql_mode                                                                                                         |
+--------------------------------------------------------------------------------------------------------------------+
| ONLY_FULL_GROUP_BY,STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER |
+--------------------------------------------------------------------------------------------------------------------+

Offline

#2 2018-06-02 09:51:18

KKAdmin
Guest
From: Germany
Registered: 2010-03-05
Posts: 867

Re: How to fix "SQL strict mode is not fully enabled..."?

Are you a developer ?

If not please just disable debug mode. (click on the red bug button. if the button is white all is good.)


You can mark this threat as [resolved] in subject of your threat. (This is only available edit of the first post.) It is good for users who help others to quickly see which post is still open.
##############################################
GLPI 9.2.3 /Ubuntu 16.04.4 LTS
Apache/2.4.18 (Ubuntu) - PHP 7.0.30-0ubuntu0.16.04.1 - MySQL 5.7.22-0ubuntu0.16.04.1

Offline

#3 2018-06-04 19:04:20

dparker
Guest
Registered: 2016-05-17
Posts: 8

Re: How to fix "SQL strict mode is not fully enabled..."?

Okay, well I have done that in the past to suppress the error, but after the latest GLPI upgrade it turned debug mode back on and I wanted to take a stab at it again. Thanks for the reply.

Offline

#4 2018-06-04 19:38:34

KKAdmin
Guest
From: Germany
Registered: 2010-03-05
Posts: 867

Re: How to fix "SQL strict mode is not fully enabled..."?

Debug mode is not necessary for normal work. You have only to activate it if you have a problem (bug) and the developer needs more information to solve it


You can mark this threat as [resolved] in subject of your threat. (This is only available edit of the first post.) It is good for users who help others to quickly see which post is still open.
##############################################
GLPI 9.2.3 /Ubuntu 16.04.4 LTS
Apache/2.4.18 (Ubuntu) - PHP 7.0.30-0ubuntu0.16.04.1 - MySQL 5.7.22-0ubuntu0.16.04.1

Offline

Board footer

Powered by FluxBB