You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-01-29 21:50:46

eulogy
Guest
Registered: 2013-10-11
Posts: 112

Email import issue with single quotes

GlPI version 9.2.1
Hi good people,  anyone has seen or fixed this?

*** MySQL query error:
  SQL: INSERT
                   INTO `glpi_tickets` (`content`,`name`,`urgency`,`requesttypes_id`,`entities_id`,`status`,`impact`,`priority`,`users_id_recipient`,`itilcategories_id`,`date`,`global_validation`,`type`,`date_creation`,`date_mod`) VALUES ('-----....
...Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '') de la lista (por ejemplo,\n ) con la palabra 'help' en ' at line 2
  Backtrace :
  inc/commondbtm.class.php:504                       
  inc/commondbtm.class.php:928                       CommonDBTM->addToDB()
  inc/mailcollector.class.php:596                    CommonDBTM->add()
  inc/mailcollector.class.php:1659                   MailCollector->collect()
  :                                                  MailCollector::cronMailgate()
  inc/crontask.class.php:832                         call_user_func()
  front/cron.php:87                                  CronTask::launch()

it seems to be, when an email has single quotes it will cause the issue so it's impossible to import the email.

Best regards.

Last edited by eulogy (2018-02-04 03:32:54)

Offline

#2 2018-02-06 12:20:17

djwhite
Guest
Registered: 2015-10-25
Posts: 21

Re: Email import issue with single quotes

Hi there

I came across this and the fix is to turn off "Use rich text for helpdesk" in Setup -> General -> Assistance.

Regards

David

Offline

#3 2018-02-06 17:33:58

eulogy
Guest
Registered: 2013-10-11
Posts: 112

Re: Email import issue with single quotes

Thanks David for your reply, that option is already turned off.

This issue is when someone emails to the receiver and in the body text exists the apostrophe character, it is a PHP error like shown before, already upgraded my PHP version to 5.6.33, also upgraded to MariaDB 10.0.32.

I also sent a test email to my GLPI receiver with the apostrophe 'single quotation' and the error shows up.

This issue was fixed before as described in this link https://github.com/glpi-project/glpi/co … b2ed7005e8 but for some reason it's happening again and can't determine how to fix it.

Regards.

Offline

#4 2018-07-13 11:54:44

elliot01
Guest
From: England
Registered: 2010-03-23
Posts: 201

Re: Email import issue with single quotes

I can agree with this.

We're using v9.2.4 and an email with the word "don't" won't make it through the mail receiver. If we resend the email changing the word to "dont", it's successful.


CentOS v6 / MariaDB 10 / GLPI v9 / OCS v2 / FusionInventory
600+ Computers / 600+ users

Offline

Board footer

Powered by FluxBB