You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-06-29 14:35:18

MaximePRLT
Guest
Registered: 2018-06-29
Posts: 4

[RESOLU] Mise à jour Plugin Fusion Inventory 9.3+1.0

Bonjour,
Je viens d'installer la dernière version de GLPI, soit la 9.3
J'ai tenté une mise à jour du plugin FUSIONINVENTORY (9.3+1.0). Malheureusement, celle-ci ne se déroule pas correctement.
Voici le message d'erreur qui s'affiche en mode debug.

PHP Notice: Undefined variable: result in /var/www/html/glpi/plugins/fusioninventory/install/update.php at line 4140

Fatal error: Uncaught Error: Call to a member function fetch_array() on null in /var/www/html/glpi/inc/dbmysql.class.php:299 Stack trace: #0 /var/www/html/glpi/plugins/fusioninventory/install/update.php(4140): DBmysql->fetch_array(NULL) #1 /var/www/html/glpi/plugins/fusioninventory/install/update.php(427): do_printer_migration(Object(Migration)) #2 /var/www/html/glpi/plugins/fusioninventory/hook.php(825): pluginFusioninventoryUpdate('9.3+1.0', 'Migration') #3 /var/www/html/glpi/inc/plugin.class.php(701): plugin_fusioninventory_install() #4 /var/www/html/glpi/front/plugin.form.php(47): Plugin->install('132') #5 {main} thrown in /var/www/html/glpi/inc/dbmysql.class.php on line 299

J'avoue ne pas savoir où chercher pour résoudre ce problème et parvenir à mettre à jour le plugin.
L'un d'entre vous pourrait-il m'assister s'il vous plait?

GLPI tourne sous une VM UBUNTU 16.04 LTS
APACHE 2.4.18
MARIADB 10.2.16
PHP 7.0.30

Last edited by MaximePRLT (2018-07-10 11:06:36)


Glpi : 9.3 / Os : Ubuntu 16.04 Lts / Apache : 2.4.18 / Mariadb : 10.2.16 / Php : 7.0.30

Offline

#2 2018-07-03 11:34:48

MalcolmSio
Guest
Registered: 2016-02-02
Posts: 120

Re: [RESOLU] Mise à jour Plugin Fusion Inventory 9.3+1.0

Salut!

J'ai trouvé ça sur le net : http://forum.glpi-project.org/viewtopic.php?id=159944
Pour faire simple, tu vas chercher le .tar de la nouvelle version de FI, tu déplaces l'ancien dossier fusion puis dézip le nouveau dans /glpi/plugins et le reste se déroule via l'interface graphique.

Je rencontre aussi des problèmes pour mettre à jour mon plugin.
Mon problème est légèrement différent car moi j'arrive à le mettre à jour par contre, je n'arrive pas à récupérer mes données...

Malcolm


GLPI 9.2.4
CentOS 7

Offline

#3 2018-07-03 13:48:50

MaximePRLT
Guest
Registered: 2018-06-29
Posts: 4

Re: [RESOLU] Mise à jour Plugin Fusion Inventory 9.3+1.0

Bonjour,
Merci MalcomSio. J'ai testé ta soluce. Malheureusement elle ne fonctionne pas.
Le message d'erreur reste identique malgré tout


Glpi : 9.3 / Os : Ubuntu 16.04 Lts / Apache : 2.4.18 / Mariadb : 10.2.16 / Php : 7.0.30

Offline

#4 2018-07-09 10:45:43

MaximePRLT
Guest
Registered: 2018-06-29
Posts: 4

Re: [RESOLU] Mise à jour Plugin Fusion Inventory 9.3+1.0

Bonjour,
Je me permets de remonter un peu le sujet.
Quelqu’un a t-il déjà rencontré ce message? Si oui, avez-vous réussi à corriger et comment?
Merci de l'attention que vous porterez à ma demande.


Glpi : 9.3 / Os : Ubuntu 16.04 Lts / Apache : 2.4.18 / Mariadb : 10.2.16 / Php : 7.0.30

Offline

#5 2018-07-10 11:07:50

MaximePRLT
Guest
Registered: 2018-06-29
Posts: 4

Re: [RESOLU] Mise à jour Plugin Fusion Inventory 9.3+1.0

La dernière version du plugin (Version 9.3+1.1) résout le problème de mise à jour.
Merci pour le travail réalisé. smile


Glpi : 9.3 / Os : Ubuntu 16.04 Lts / Apache : 2.4.18 / Mariadb : 10.2.16 / Php : 7.0.30

Offline

Board footer

Powered by FluxBB