You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-04-20 12:02:44

clafFR
Guest
Registered: 2018-04-20
Posts: 4

"simple" mise à niveau de 0.90 à 9.1 suivie d'une erreur 403 Forbidden

Bonjour

Actuellement ma solution GLPi se trouve sur une VM DEBIAN 7 avec Apache 2.2.22 - Mysql 5 - PHP 5.4.45

Bien que j'utilise depuis des années GLPi (7 ans ?, j'en suis très satisfait), je ne suis pas très à l'aise avec son installation ; et encore moins sous un linux.

A la lecture de la documentation GLPI concernant la migration, je suis devenu enthousiaste et je me suis lancé.

J'ai procédé comme suit :

sur l'interface web GLPi
1/ Sauvegarde des bases GLPi par le menu "Maintenance"

en mode console sur la VM Débian et logué "root" (pas bien! ok)

2/ Copie de sécurité
rsync -av /glpi/ /glpiOld2

3/ Vidage du répertoire /var/www/glpi/ y compris les fichiers cachés
rm -Rv /var/www/glpi/* /var/www/glpi/.*

3/ copie de glpi9.1
rsync -R /usb/glpi91/ /var/www/glpi

4/ octroie des droits 775 sur les répertoires fichiers et config
chmod -R 775 /var/www/glpi/files /var/www/glpi/config

5/ changement de propriétaire pour les dits fichiers
chown -R www-data:root /var/www/glpi

6/ redémarrage du serveur web
service apache2 stop
service apache2 start

7/ tentative échouée d'accès au site web GLPi à partir du pc d'où cela fonctionnait immédiatement avant ces "simples" manipulations. Je précise qu'elles n'ont touché qu'au répertoire glpi sans toucher aux configuration des autres services (apache2, php, MySql, ...)
erreur du navigateur sur la sécurité TLS

8/ Après des recherches qui me mènent vers des zones où je n'ai pas de compétences suffisantes (administration apache2, PHP, certificats, ...), j'efface le répertoire /var/www/glpi (et par manque de temps aussi)

9/ je rétabli l'ancien glpi 0.9 avec les permissions telles quelles

10/ je redémarre le serveur apache2

11/ je tente l'accès au site web et j'obtiens l'échec suivant
Forbidden
You don't have permission to access /glpi/ on this server

Cela paraît résulter d'un problème de droits, mais je ne vois pas où ça coince.

Je suis preneur d'un point de vue d'expert.

Merci d'avance.

Offline

#2 2018-04-20 12:20:47

clafFR
Guest
Registered: 2018-04-20
Posts: 4

Re: "simple" mise à niveau de 0.90 à 9.1 suivie d'une erreur 403 Forbidden

Le titre est un peu faussé car l'erreur 403 Forbidden apparaît après la tentative de retour à la situation antérieure fonctionnelle avec glpi 0.9x

Offline

#3 2018-04-20 13:02:51

clafFR
Guest
Registered: 2018-04-20
Posts: 4

Re: "simple" mise à niveau de 0.90 à 9.1 suivie d'une erreur 403 Forbidden

en résumé
quand je passe de la glpi-0.9 0 la glpi-9.1 j'ai un problème de certificat pour accéder au site web https://"localhost"/ et je ne peux lancer la phase de mise à jour
quand je tente un retour à la situation antérieure glpi-0.9, j'ai un problème de droits (?) et j'obtiens Forbidden erreur 403

Offline

#4 2018-04-20 16:29:08

bzh
Guest
Registered: 2016-09-25
Posts: 387

Re: "simple" mise à niveau de 0.90 à 9.1 suivie d'une erreur 403 Forbidden

Je voie un oublie par rapport a ce que je fait restart mysql

Tu as une interface graphique ?


Virtual Box \ Debian 8 \ GLPI 9.4

Offline

#5 2018-04-20 16:35:29

bzh
Guest
Registered: 2016-09-25
Posts: 387

Re: "simple" mise à niveau de 0.90 à 9.1 suivie d'une erreur 403 Forbidden

Dans ton cas et là ou tu en es,

je pense que tu devrai faire une machine virtuel avec avec la version "ancienne" sur la quel tu fait une fois que cela fonction une copie de l'image disque,

une autre vituel avec la nouvelle version (vide sans data)

cela vas te permettre de pour voir l'utilisé sans risque ! pour la 1 (l'ancienne)


Virtual Box \ Debian 8 \ GLPI 9.4

Offline

#6 2018-04-21 08:49:04

clafFR
Guest
Registered: 2018-04-20
Posts: 4

Re: "simple" mise à niveau de 0.90 à 9.1 suivie d'une erreur 403 Forbidden

Merci de ton avis BZH

C'est vrai que j'ai pas arrêté tous les services lorsque j'ai touché à GLPi. J'ai observé que PHPMyAdmin était toujours accessible lorsque GLPi ne l'était plus. Donc je me suis satisfait de ce résultat.
C'est vraiment localisé au répertoire GLPi il me semble.
Faire des machines virtuelles et tout refaire me semble assez lourd juste parce que j'ai un "petit" problème de droits que je surmonte pas. Si je n'ai pas les compétences pour ce problème de droits, je vais pas me risquer à repartir de zéro.
En plus l'urgence où je suis maintenant c'est de remettre l'ancien GLPi en production.
L'idée de faire une VM de préparation est incontournable désormais pour pas casser la VM en production.
Mais comme je l'ai dit dans le message de départ, je suis parti un peu trop "enthousiaste" suite à la simplicité de la mise à jour présentée dans la procédure officielle.

Offline

#7 2018-04-23 08:09:34

bzh
Guest
Registered: 2016-09-25
Posts: 387

Re: "simple" mise à niveau de 0.90 à 9.1 suivie d'une erreur 403 Forbidden

Tu ne devrais pas avoir trop de pb !

une machine virtuel de secoure avec virtual box ! cela peut aller vite (la plus grand partie du temps c'est l'installation de l'OS) aller courage ;-)


regarde ce lien :
https://www.supinfo.com/articles/single … ation-glpi

même si la version de glpi est différent cela fonctionne

Last edited by bzh (2018-04-23 08:13:11)


Virtual Box \ Debian 8 \ GLPI 9.4

Offline

Board footer

Powered by FluxBB