You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-04-11 16:14:04

amma35
Moderator
Registered: 2017-02-08
Posts: 32

[Plugin webservice] 9.2 Fatal error

Are you planning to release this plugin for GLPI version 9.2?

I tested the version of the trunk, a small error returned:

In the consultation of the "webservices" methods of the client:

Fatal error: Cannot use [] for reading in D:\wamp64\www\glpi921\plugins\webservices\inc\methodinventaire.class.php on line 745

Patch :

Index: methodinventaire.class.php
===================================================================
--- methodinventaire.class.php	(revision 453)
+++ methodinventaire.class.php	(working copy)
@@ -742,7 +742,7 @@
          return $resp;
       }
 
-      $resp  = array()[];
+      $resp  = [];

Thank you in advance

Offline

#2 2018-04-11 16:20:47

btry
Guest
Registered: 2015-10-01
Posts: 187

Re: [Plugin webservice] 9.2 Fatal error

Hi

The plugin is hosted here: https://forge.glpi-project.org/projects/webservices

You should request to be reporter or contributor for the plugin.


Always run an upgrade task on a testing instance before running it on production ! Always backup before any upgrade task !

Flyve MDM: https://github.com/flyve-mdm/glpi-plugin
Formcreator: https://github.com/pluginsGLPI/formcreator

Offline

#3 2018-04-17 16:21:30

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,104

Re: [Plugin webservice] 9.2 Fatal error

amma35: already corrected for me.
I wait final tests from a user to publish the plugin (i have no time to test all parts)


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

Board footer

Powered by FluxBB