You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-01-23 16:18:44

bcarbo
Guest
Registered: 2018-01-23
Posts: 2

Installation ArchiRes 2.5.0 sur 9.2.1

Bonjour,.

Lorsque j'essaie d'installer le plugin, j'ai une erreur HTTP 500 lorsque je clic sur installer.

Dans les logs Apache j'ai ceci:
[Tue Jan 23 14:51:41.891711 2018] [:error] [pid 640] [client 172.16.2.195:62230] PHP Fatal error:  Uncaught Error: Call to a member function tableExists() on null in /var/www/glpi/plugins/archires/hook.php:40\nStack trace:\n#0 /var/www/glpi/inc/plugin.class.php(730): plugin_archires_install()\n#1 /var/www/glpi/front/plugin.form.php(48): Plugin->install('12')\n#2 {main}\n  thrown in /var/www/glpi/plugins/archires/hook.php on line 40, referer: http://srvglpi1/glpi/front/plugin.php

Une idée sur le souci?
Merci d'avance et meilleures salutations.

Offline

#2 2018-01-26 18:29:07

Megachip
Guest
Registered: 2014-05-02
Posts: 80

Re: Installation ArchiRes 2.5.0 sur 9.2.1

Fatal error: Uncaught Error: Call to a member function tableExists() on null in /usr/share/glpi/plugins/archires/hook.php:40 Stack trace: #0 /usr/share/glpi/inc/plugin.class.php(730): plugin_archires_install() #1 /usr/share/glpi/front/plugin.form.php(48): Plugin->install('1') #2 {main} thrown in /usr/share/glpi/plugins/archires/hook.php on line 40

same same on install and upgrade sad

Last edited by Megachip (2018-01-26 18:29:31)

Offline

#3 2018-02-01 15:09:57

reflectedsamir
Guest
Registered: 2018-01-31
Posts: 2

Re: Installation ArchiRes 2.5.0 sur 9.2.1

There is a bug in the hook.php on line 40. It is a simple typo which is not tolerated on *nix systems.

Old code:

if (!$DB->tableExists("glpi_plugin_archires_config")
       && !$db->tableExists("glpi_plugin_archires_views")) {
      $DB->runFile(GLPI_ROOT ."/plugins/archires/sql/empty-2.2.sql");

New code:

if (!$DB->tableExists("glpi_plugin_archires_config")
       && !$DB->tableExists("glpi_plugin_archires_views")) {
      $DB->runFile(GLPI_ROOT ."/plugins/archires/sql/empty-2.2.sql");

Notice the lowercase 'db' in the first block and the uppercase 'DB' in the second block. This should fix it for you.

Offline

#4 2018-02-02 17:46:51

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,964

Re: Installation ArchiRes 2.5.0 sur 9.2.1

Ticket opened in the forge of the plugin and corrected: https://forge.glpi-project.org/issues/5547


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#5 2018-02-13 11:51:38

bcarbo
Guest
Registered: 2018-01-23
Posts: 2

Re: Installation ArchiRes 2.5.0 sur 9.2.1

Merci beaucoup pour la correction.

C'est parfait! :-)

Offline

Board footer

Powered by FluxBB