You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-01-11 17:12:40

Zero-Days
Guest
From: Chartres
Registered: 2018-01-09
Posts: 25

Bug plugin datainjection

Bonjour,

J'ai une erreur au niveau de l'installation du plugin depuis que je suis passer en version 9.2.1 sur glpi la dernière sortie. J'ai un problème au niveau du plugin datainjection, je pense qu'il n'est pas encore optimisé pour cette version. Quand j'installe le plugin dans ma VM linux tout se passe bien, ensuite je regarde dans les plugins de glpi il est référencé mais il m'affiche un message d’erreur  comme quoi

This plugin requires GLPI 0.85 or higher 

pour corriger se problème je modifie le fichier "setup.php" à la place de :

 if (version_compare(GLPI_VERSION,'0.85','lt') || version_compare(GLPI_VERSION,'9.2','ge')) {
      _e('This plugin requires GLPI 0.85 or higher', 'datainjection'); 

je met :

 if (version_compare(GLPI_VERSION,'0.85','lt') || version_compare(GLPI_VERSION,'9.3','ge')) {
      _e('This plugin requires GLPI 0.85 or higher', 'datainjection'); 

en remplaçant 9.2 par 9.3. Ensuite je retourne dans l'onglet plugins de glpi et je peut installer et activer le plugins. Mon problème se situe juste après. Quand je veut crée un modèle sur datainjection il manque des champs comme "sauvegarder " et "type de données a insérer".
Type de donnée a insérer est présent mais aucun champs n'apparait.
Quand je me met en mode débug tout en bas de la page j'obtiens une erreur critique

 Fatal error: Class 'NetworkEquipmentFirmware' not found in /var/www/glpi/plugins/datainjection/inc/networkequipmentfirmwareinjection.class.php on line 36 

Pourriez-vous m'aidez a corrigé le problème d'affichage des champs et faire revenir le bouton sauvegarde car il m'est impossible de sauvegarder un modèle pour pouvoir balancer mon csv ?

Je n'ai pas préciser mais j'utilise la dernière version de datainjection "2.4.2".

Voici quelques screenshot :

576372screenshotglpi4.png

632004screenshotglpi5.png


« L’échec est la base du succès »

[しっぱいはせいこうのもといなり, shippai wa seikou no motoi nari] 失敗 / 成功 – Shippai / Seikou

Offline

#2 2018-01-11 17:32:16

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 4,040

Re: Bug plugin datainjection

pour corriger se problème je modifie le fichier "setup.php" à la place de

ça ne corrige pas le problème ça crée un autre problème.

il y a un test avant l'install pour vérifier que c'est compatible. Casser le thermomètre n'a jamais fait baisser la fievre, supprimer le test ne rend pas le plugin compatible avec la 9.2.

la classe networkequipmentfirmware.class.php existe en 9.1 mais plus en 9.2 (c'est géré autrement) donc le plugin ne la trouve pas.


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+formcreator2.5.2 PHP7.0 Mariadb10
*GLPI 9.2.4(behaviours1.5.2+fusion9.2+1.0+applicatifs2.3.0+dashboard 0.8.9)hebergé sur serveur mutualisé.
*GLPI 9.3  en test (ubuntu 16.04 mariadb 10.2.4) (attente plugin compatible avant mise en prod)

Offline

#3 2018-01-11 17:36:44

Zero-Days
Guest
From: Chartres
Registered: 2018-01-09
Posts: 25

Re: Bug plugin datainjection

Comment puis-je faire pour injecter mon fichier csv sans le plugin datainjection existe-til un autre plugins ?


« L’échec est la base du succès »

[しっぱいはせいこうのもといなり, shippai wa seikou no motoi nari] 失敗 / 成功 – Shippai / Seikou

Offline

#4 2018-01-11 17:39:37

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 4,040

Re: Bug plugin datainjection

attendez une version compatible du plugin, ou ecrivez un client pour l'API qui lit le csv et créée vos items .

que voulez vous injecter ? des ordinateurs ? des téléphones ? des tickets ?


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+formcreator2.5.2 PHP7.0 Mariadb10
*GLPI 9.2.4(behaviours1.5.2+fusion9.2+1.0+applicatifs2.3.0+dashboard 0.8.9)hebergé sur serveur mutualisé.
*GLPI 9.3  en test (ubuntu 16.04 mariadb 10.2.4) (attente plugin compatible avant mise en prod)

Offline

#5 2018-01-11 17:41:24

Zero-Days
Guest
From: Chartres
Registered: 2018-01-09
Posts: 25

Re: Bug plugin datainjection

Je veux injecter des ordinateurs , périphériques , téléphones et des pièces détachées comme des cartes mères ou autres composants d'ordinateurs.


« L’échec est la base du succès »

[しっぱいはせいこうのもといなり, shippai wa seikou no motoi nari] 失敗 / 成功 – Shippai / Seikou

Offline

#6 2018-02-27 13:47:42

noircc
Guest
Registered: 2015-10-09
Posts: 51

Offline

Board footer

Powered by FluxBB