You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-10-20 09:04:40

stournier
Guest
Registered: 2005-03-08
Posts: 126

The requested URL /plugins/ocsinventoryng/front/ocsng.php was not foun

Bonjour, j'ai mi a jour ocs en 2.3 depuis le repo remi.

Et meme avant que je mette a jour glpi de 9.1.2 vers 9.2 j'avais ce message.

Est ce que quelqu'un a une idée ?

Merci


GLPI 9.1.2 sur CentOS Linux release 7.2.1511 (Core) / OCS-NG 2.3 sur même machine
httpd-2.4.6-40.el7.centos.4.x86_64 / php-common-5.6.31-1.el7.remi.x86_64
PHP 5.6.31 (cli) (built: Jul  6 2017 08:06:11) / Zend Engine v2.6.0, with Zend OPcache v7.0.6-dev
mariadb-5.5.50-1.el7_2.x86_64 / mariadb-server-5.5.50-1.el7_2.x86_64

Offline

#2 2017-10-23 16:00:38

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,879

Re: The requested URL /plugins/ocsinventoryng/front/ocsng.php was not foun

Vous avez bien le plugin OCSInventory activé dans la liste des plugins de GLPI ?


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#3 2017-10-23 16:03:05

stournier
Guest
Registered: 2005-03-08
Posts: 126

Re: The requested URL /plugins/ocsinventoryng/front/ocsng.php was not foun

oui je l'ai meme mi a jour et pareil.

Mais j'avais le même soucis avec la dernière version, mais on dirait un problème de droits car on dirait que cela fait pareil avec un autre plugin que j'ai testé formcreator.

Mais dans le dossier il y a de bon droit et selinux est désactivé.


GLPI 9.1.2 sur CentOS Linux release 7.2.1511 (Core) / OCS-NG 2.3 sur même machine
httpd-2.4.6-40.el7.centos.4.x86_64 / php-common-5.6.31-1.el7.remi.x86_64
PHP 5.6.31 (cli) (built: Jul  6 2017 08:06:11) / Zend Engine v2.6.0, with Zend OPcache v7.0.6-dev
mariadb-5.5.50-1.el7_2.x86_64 / mariadb-server-5.5.50-1.el7_2.x86_64

Offline

#4 2017-10-24 17:05:53

stournier
Guest
Registered: 2005-03-08
Posts: 126

Re: The requested URL /plugins/ocsinventoryng/front/ocsng.php was not foun

quelqu'un a une idée aussi ,en fait ca vient de linux/HTTPD car j'ai vraiment pas accès au plugin, alors que si je vais d'en plugin je voit les plugin et les installer mais pas les utiliser.

Que dois-je verifier ?


GLPI 9.1.2 sur CentOS Linux release 7.2.1511 (Core) / OCS-NG 2.3 sur même machine
httpd-2.4.6-40.el7.centos.4.x86_64 / php-common-5.6.31-1.el7.remi.x86_64
PHP 5.6.31 (cli) (built: Jul  6 2017 08:06:11) / Zend Engine v2.6.0, with Zend OPcache v7.0.6-dev
mariadb-5.5.50-1.el7_2.x86_64 / mariadb-server-5.5.50-1.el7_2.x86_64

Offline

#5 2017-10-27 14:32:17

stournier
Guest
Registered: 2005-03-08
Posts: 126

Re: The requested URL /plugins/ocsinventoryng/front/ocsng.php was not foun

Que doit-on verifier sou linux pour les droits ? car glpi voit bien le plugin et on peut l'installer, mais quand on essaye d'y acceder cela donne cette erreur, avec ocs et formcreator .

Merci


GLPI 9.1.2 sur CentOS Linux release 7.2.1511 (Core) / OCS-NG 2.3 sur même machine
httpd-2.4.6-40.el7.centos.4.x86_64 / php-common-5.6.31-1.el7.remi.x86_64
PHP 5.6.31 (cli) (built: Jul  6 2017 08:06:11) / Zend Engine v2.6.0, with Zend OPcache v7.0.6-dev
mariadb-5.5.50-1.el7_2.x86_64 / mariadb-server-5.5.50-1.el7_2.x86_64

Offline

#6 2017-10-27 15:02:29

stournier
Guest
Registered: 2005-03-08
Posts: 126

Re: The requested URL /plugins/ocsinventoryng/front/ocsng.php was not foun

J'ai ca comme message d'erreur dans error de apache :
[Fri Oct 27 11:54:02.798352 2017] [autoindex:error] [pid 4003] [client 128.2.150.110:55436] AH01276: Cannot serve directory /var/lib/ocsinventory-reports/plugins/: No matching DirectoryIndex (index.html,index.php) found, and server-generated directory index forbidden by Options directive


GLPI 9.1.2 sur CentOS Linux release 7.2.1511 (Core) / OCS-NG 2.3 sur même machine
httpd-2.4.6-40.el7.centos.4.x86_64 / php-common-5.6.31-1.el7.remi.x86_64
PHP 5.6.31 (cli) (built: Jul  6 2017 08:06:11) / Zend Engine v2.6.0, with Zend OPcache v7.0.6-dev
mariadb-5.5.50-1.el7_2.x86_64 / mariadb-server-5.5.50-1.el7_2.x86_64

Offline

#7 2017-10-29 13:20:39

tsmr
GLPI-DEV
From: Rennes
Registered: 2005-08-26
Posts: 11,630
Website

Re: The requested URL /plugins/ocsinventoryng/front/ocsng.php was not foun

Offline

#8 2017-10-31 15:42:14

stournier
Guest
Registered: 2005-03-08
Posts: 126

Re: The requested URL /plugins/ocsinventoryng/front/ocsng.php was not foun

Merci, mais j'ai not found pas fobidden et j'ai le même problème avec le plugin formcreator. 

Not Found

The requested URL /plugins/formcreator/front/form.php was not found on this server.

Not Found

The requested URL /plugins/ocsinventoryng/front/ocsng.php was not found on this server.

Pour moi c'est plus un problème de droit mais :

drwxrwxrwx. 37 apache apache     4096  9 févr.  2017 glpi

drwxrwxrwx. 11 apache apache   4096 10 oct.  15:16 formcreator
-rwxrwxrwx.  1 root   root   591687 10 oct.  15:20 glpi-formcreator-2.6.0.tar.bz2
drwxrwxrwx. 12 apache apache   4096 19 oct.  18:12 ocsinventoryng


Et j'ai désactivé le selinux.

et dans le fichier /etc/httpd/conf.d/z-ocsinventory-server.conf

j'ai :
#Web Service for plugin engine
  <Location /ocsplugins>
    <IfModule mod_authz_core.c>
      # Apache 2.4
      Require local
    </IfModule>
    <IfModule !mod_authz_core.c>
      # Apache 2.2
      order deny,allow
      allow from 127.0.0.1
    </IfModule>
    SetHandler perl-script
    PerlHandler Apache::Ocsinventory::Plugins::Apache
  </Location>

D'autres idees ?


GLPI 9.1.2 sur CentOS Linux release 7.2.1511 (Core) / OCS-NG 2.3 sur même machine
httpd-2.4.6-40.el7.centos.4.x86_64 / php-common-5.6.31-1.el7.remi.x86_64
PHP 5.6.31 (cli) (built: Jul  6 2017 08:06:11) / Zend Engine v2.6.0, with Zend OPcache v7.0.6-dev
mariadb-5.5.50-1.el7_2.x86_64 / mariadb-server-5.5.50-1.el7_2.x86_64

Offline

#9 2017-10-31 15:45:46

stournier
Guest
Registered: 2005-03-08
Posts: 126

Re: The requested URL /plugins/ocsinventoryng/front/ocsng.php was not foun

Et j'ai ca comme erreur dans les logs error de apache :
[Tue Oct 31 14:37:17.573164 2017] [autoindex:error] [pid 385] [client 128.2.150.110:63501] AH01276: Cannot serve directory /var/lib/ocsinventory-reports/plugins/: No matching DirectoryIndex (index.html,index.php) found, and server-generated directory index forbidden by Options directive


GLPI 9.1.2 sur CentOS Linux release 7.2.1511 (Core) / OCS-NG 2.3 sur même machine
httpd-2.4.6-40.el7.centos.4.x86_64 / php-common-5.6.31-1.el7.remi.x86_64
PHP 5.6.31 (cli) (built: Jul  6 2017 08:06:11) / Zend Engine v2.6.0, with Zend OPcache v7.0.6-dev
mariadb-5.5.50-1.el7_2.x86_64 / mariadb-server-5.5.50-1.el7_2.x86_64

Offline

#10 2017-11-13 10:47:35

stournier
Guest
Registered: 2005-03-08
Posts: 126

Re: The requested URL /plugins/ocsinventoryng/front/ocsng.php was not foun

Est ce que d'autres personnes a d'autres idées par hasard?
Pour moi cela viens de linux et pas de glpi car cela me fait la même chose pour d'autres plugins.

Merci


GLPI 9.1.2 sur CentOS Linux release 7.2.1511 (Core) / OCS-NG 2.3 sur même machine
httpd-2.4.6-40.el7.centos.4.x86_64 / php-common-5.6.31-1.el7.remi.x86_64
PHP 5.6.31 (cli) (built: Jul  6 2017 08:06:11) / Zend Engine v2.6.0, with Zend OPcache v7.0.6-dev
mariadb-5.5.50-1.el7_2.x86_64 / mariadb-server-5.5.50-1.el7_2.x86_64

Offline

#11 2017-11-14 11:07:31

stournier
Guest
Registered: 2005-03-08
Posts: 126

Re: The requested URL /plugins/ocsinventoryng/front/ocsng.php was not foun

Vous pouvez le clore.

Grace a un ami pro linux, en installant par yum ocsreports, il m'a créé plein de fichier .conf qui sont incluse dans apache .
avec le IncludeOptional conf.d/*.conf et dans l'un de ses fichier conf pour ocs, il y avait un /plugins en dehors d'un virtualhost, qui me changeait du coup tout les emplacements de dossier plugins .


GLPI 9.1.2 sur CentOS Linux release 7.2.1511 (Core) / OCS-NG 2.3 sur même machine
httpd-2.4.6-40.el7.centos.4.x86_64 / php-common-5.6.31-1.el7.remi.x86_64
PHP 5.6.31 (cli) (built: Jul  6 2017 08:06:11) / Zend Engine v2.6.0, with Zend OPcache v7.0.6-dev
mariadb-5.5.50-1.el7_2.x86_64 / mariadb-server-5.5.50-1.el7_2.x86_64

Offline

Board footer

Powered by FluxBB