You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-09-21 10:33:30

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Update to latest development version from previous development version

Hello all,

I updated GLPI from the stable version 9.1 to the development version 9.2-RC1.
But, when I try to update the 9.2-RC1 version to the 9.2-RC2 version, I get a message saying that it is not possible to update from a development version to another development version.

So, what can I do to install the 9.2-RC2 development version?

Thank you for ay help.

Offline

#2 2017-09-21 13:34:37

Langundo
Guest
Registered: 2016-07-21
Posts: 17

Re: Update to latest development version from previous development version

Hi,
these steps are working for me:
- create a sql-dump of your database
- delete the config_db.php in glpi/config
- install the 9.2-RC2
- restore database


work: AMPPS (Windows) - PHP 5.4 - MySQL 5.5 - GLPI 9.1.6
test: Debian Stretch - PHP 7.0 - MariaDB 10.1 - GLPI 9.1.6 / bugfix / master

Offline

#3 2017-09-22 16:57:12

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: Update to latest development version from previous development version

Hi Langundo,

Thank you for your help.
I did as you wrote, but it did not work: I still got the same message.
When asked whether to install or upgrade, which option did you choose?
Also, I did not delete the existing glpi database.

Any other clue?

Thank again.

Offline

#4 2017-09-22 20:17:42

Langundo
Guest
Registered: 2016-07-21
Posts: 17

Re: Update to latest development version from previous development version

Hi netsyspro,
I use the install option. I think this creates a fresh, empty database.
Then you can logon with the default glpi account and restore your sql-dump.

Hope this will work for you too.


work: AMPPS (Windows) - PHP 5.4 - MySQL 5.5 - GLPI 9.1.6
test: Debian Stretch - PHP 7.0 - MariaDB 10.1 - GLPI 9.1.6 / bugfix / master

Offline

#5 2017-09-27 12:58:21

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: Update to latest development version from previous development version

Langundo,

I think I tried that as well, but it didn't work.
Now, that the final version of 9.2 is out, I tried to update to version 9.2 from 9.2-RC1, but got the following error msg:
You are trying to use GLPI with outdated files compared to the version of the database. Please install the correct GLPI files corresponding to the version of your database.

Should I post this question in the "Installation GLPI sur Gnu/Linux" forum?
What do you suggest?

Thank you.

Offline

#6 2017-09-28 11:19:03

Gisko
Guest
Registered: 2011-08-25
Posts: 10

Re: Update to latest development version from previous development version

Same Error her :-/ i will update from 9.2-RC2 to 9.2

> You are trying to use GLPI with outdated files compared to the version of the database. Please install the correct GLPI files corresponding to the version of your database.

Offline

#7 2017-09-28 15:05:37

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: Update to latest development version from previous development version

OK. I'm going to try posting to the "Installation GLPI sur Gnu/Linux" forum.

Offline

#8 2017-10-09 17:55:47

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: Update to latest development version from previous development version

Just for your information: I haven't had any success yet.

Offline

Board footer

Powered by FluxBB