You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-09-12 14:33:37

fleger
Guest
Registered: 2014-07-02
Posts: 1

Error during GLPI v9.1.2 upgrade process

Hi,

I have GLPI installed v9.1.2 + FusionInventory 1.1, on web hosting, professional plan. I upgraded GLPTI to v9.1.6 with the official procedure "http://glpi-project.org/spip.php?article172".
The result seems OK but some problems occurs :

1) During upgrade process an error stop the process after "optimisation glpi_logs" :

Fatal error: Call to a member function fetch_assoc() on boolean in /home/user/www/glpi/inc/dbmysql.class.php on line 308.

2) In the glpi/files/_log/sql-errors.log :

2017-09-12 13:22:21
  *** MySQL query error:
  SQL: SELECT COUNT(*) AS cpt
             FROM `glpi_logs` WHERE itemtype = \'PluginFusioninventoryInventoryRuleEntity\'
                                          AND items_id = \'51\'
  Error: Table './covateammpglpi/glpi_logs' is marked as crashed and last (automatic?) repair failed
  Backtrace :
  inc/db.function.php:319                           
  inc/log.class.php:93                               countElementsInTable()
  inc/commonglpi.class.php:208                       Log->getTabNameForItem()
  inc/rule.class.php:2839                            CommonGLPI->addStandardTab()
  inc/commonglpi.class.php:158                       Rule->defineTabs()
  inc/commonglpi.class.php:707                       CommonGLPI->defineAllTabs()
  inc/commonglpi.class.php:1152                      CommonGLPI->showTabsContent()
  front/rule.common.form.php:88                      CommonGLPI->display()
  ...inventory/front/inventoryruleentity.form.php:60 include()
2017-09-12 13:22:45
  *** MySQL query error:
  SQL: SELECT COUNT(*) AS cpt
             FROM `glpi_logs` WHERE itemtype = \'PluginFusioninventoryInventoryRuleEntity\'
                                          AND items_id = \'54\'
  Error: Table './covateammpglpi/glpi_logs' is marked as crashed and last (automatic?) repair failed
  Backtrace :
  inc/db.function.php:319                           
  inc/log.class.php:93                               countElementsInTable()
  inc/commonglpi.class.php:208                       Log->getTabNameForItem()
  inc/rule.class.php:2839                            CommonGLPI->addStandardTab()
  inc/commonglpi.class.php:158                       Rule->defineTabs()
  inc/commonglpi.class.php:707                       CommonGLPI->defineAllTabs()
  inc/commonglpi.class.php:1152                      CommonGLPI->showTabsContent()
  front/rule.common.form.php:88                      CommonGLPI->display()
  ...inventory/front/inventoryruleentity.form.php:60 include()
2017-09-12 13:22:55
  *** MySQL query error:
  SQL: SELECT COUNT(*) AS cpt
             FROM `glpi_logs` WHERE itemtype = \'PluginFusioninventoryInventoryRuleEntity\'
                                          AND items_id = \'54\'
  Error: Table './covateammpglpi/glpi_logs' is marked as crashed and last (automatic?) repair failed
  Backtrace :
  inc/db.function.php:319                           
  inc/log.class.php:93                               countElementsInTable()
  inc/commonglpi.class.php:208                       Log->getTabNameForItem()
  inc/rule.class.php:2839                            CommonGLPI->addStandardTab()
  inc/commonglpi.class.php:158                       Rule->defineTabs()
  inc/commonglpi.class.php:707                       CommonGLPI->defineAllTabs()
  inc/commonglpi.class.php:1152                      CommonGLPI->showTabsContent()
  front/rule.common.form.php:88                      CommonGLPI->display()
  ...inventory/front/inventoryruleentity.form.php:60 include()

Some ideas? Do I need to relaunch upgrade process?
Many thanks.

Offline

#2 2017-09-13 19:48:27

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,580

Re: Error during GLPI v9.1.2 upgrade process

Yes, as the log indicated, you must repair the glpi_logs in your database


CentOS 6.5 - PHP 5.6 - PHP 7 - MySQL 5.6  + APC + memcached
GLPI 0.90.5 SVN - GLPI 9.1.3 SVN
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

Board footer

Powered by FluxBB