You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2016-01-29 15:41:32

egpasosn
Guest
Registered: 2016-01-28
Posts: 2

"You don't have right to connect" on ver 0.90.1

Hi GLPI forum.

First I have to thanks because GLPI is a wonderful project!

I have an issue with version 0.90.1,  I updated last December and all was working good, last week we can't enter to the application, we have a message "You don't have right to connect" and the only option is to "Log in again".

I've been looking in forums and try the option of change the password directly in the BD (MySQL) with MD5, but the result is the same. If I wrote a bad password or user the message is "Incorrect user or password", so the application is looking at the BD and review the credentials.

My server is a Fedora 22, with Mariadb 10.0.21 and Apache 2.4 on a VMWare 5.

Thanks in advance! :-)

Offline

#2 2016-01-29 16:01:35

egpasosn
Guest
Registered: 2016-01-28
Posts: 2

Re: "You don't have right to connect" on ver 0.90.1

I found how to solve the issue.

I enter to /var/log/glpi/ and review all logs. In my case the sql-error.log shows :
*** MySQL query error:
  SQL: SELECT `glpi_entities`.*
                FROM `glpi_entities`
                WHERE `glpi_entities`.`id` = \'0\' LIMIT 1
  Error: Table './glpi/glpi_entities' is marked as crashed and last (automatic?) repair failed
  Backtrace :
  inc/commondbtm.class.php:191
  inc/commondbtm.class.php:164                       CommonDBTM->getFromDBByQuery()
  inc/entity.class.php:999                           CommonDBTM->getFromDB()
  inc/reservationitem.class.php:588                  Entity::getEntitiesToNotify()
  :                                                  ReservationItem::cronReservation()
  inc/crontask.class.php:799                         call_user_func()
  front/cron.php:88                                  CronTask::launch()

So I entered with "Toad for MySQL", select the table and use the repair option, it works great and now I can access to server.

So... Saludos desde México! :-)

Offline

#3 2016-02-05 20:53:16

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,360

Re: "You don't have right to connect" on ver 0.90.1

Yes you must repair crashed tables to work with GLPI


CentOS 6.5 - PHP 5.6 - PHP 7 - MySQL 5.6  + APC + memcached
GLPI 0.90.5 SVN - GLPI 9.1.3 SVN
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#4 2017-08-12 13:38:47

Srini51293
Guest
Registered: 2017-08-03
Posts: 3

Re: "You don't have right to connect" on ver 0.90.1

Hi I am new to GLPI

I facing with this problem while logging In  as user

"You don't have right to connect

             login again "

even  tried to logged in  as superadmin nothing changes,

but for one user its logins without any problem. (profile: supervisor)

why this is happening, kindly please help me.

Last edited by Srini51293 (2017-08-18 07:43:45)

Offline

#5 2017-08-16 10:03:27

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,360

Re: "You don't have right to connect" on ver 0.90.1

Version of GLPI used?
Have you change password in database?


CentOS 6.5 - PHP 5.6 - PHP 7 - MySQL 5.6  + APC + memcached
GLPI 0.90.5 SVN - GLPI 9.1.3 SVN
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#6 2017-08-18 07:45:29

Srini51293
Guest
Registered: 2017-08-03
Posts: 3

Re: "You don't have right to connect" on ver 0.90.1

I solved that issue by uninstalling and reinstalling GLPI tool in my system.
Thank you

Offline

Board footer

Powered by FluxBB