You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2014-04-14 10:06:27

fab-6z
Guest
Registered: 2014-04-03
Posts: 24

Authentification SSO

Bonjour,

J'aimerai mettre en place l'authentification SSO sur mon glpi v0.84.3
Je suis sur Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1

J'ai essayé ceci http://www.glpi-project.org/wiki/doku.p … authautoad
J'ai installé le module mod_auth_sspi.so en v.1.0.4-2.2.2 comme sur le lien
J'ai ajouté la ligne suivante dans mon httpd.conf

LoadModule sspi_auth_module modules/mod_auth_sspi.so

ainsi que

#glpi configuration
<Directory "C:/xampp/htdocs/glpi>
  Options None
  Order allow,deny
  Allow from all

  AuthName "Accès restreint"
  AuthType SSPI
  SSPIAuth On
  SSPIAuthoritative On
  SSPIOfferBasic On
  require valid-user
  </Directory>

Paramétrage du navigateur IE :
“Activer l'authentification intégrée de Windows” OK

Création d'un fichier test.php pour vérifier que les identifiants sont bien récupérés :

<?php

$user = $_SERVER["REMOTE_USER"];
$ServerGLPI = $_SERVER["HTTP_HOST"];
echo "identifiant : $user";
echo "<BR>ServerGLPI : $ServerGLPI";

$cred = explode("\\",$_SERVER["REMOTE_USER"]);
if(count($cred)==1) array_unshift($cred, "(no domain info - perhaps SSPIOmitDomain is On)");
list ($domain,$user) = $cred;

echo "<BR><BR>You appear to be user : <B>$user</B> <BR>";
echo "logged into the Windows NT domain : <B>$domain</B>";

/*echo "login : ";
echo $_SERVER["REMOTE_USER"];*/
?>

Paramétrage dans GLPI :
Authentification\Autres\Autre authentification transmise dans la requête HTTP
Champs de stockage de l'identifiant dans la requête HTTP : REMOTE_USER
Supprimer le domaine des identifiants de la forme [email protected] : Oui

Test :
http://serveurglpi.mondomaine/test.php

Résultat:

Notice: Undefined index: REMOTE_USER in C:\xampp\htdocs\test.php on line 3
identifiant :
ServerGLPI : 172.16.10.62
Notice: Undefined index: REMOTE_USER in C:\xampp\htdocs\test.php on line 8


You appear to be user :
logged into the Windows NT domain : (no domain info - perhaps SSPIOmitDomain is On)

Lorsque je vais sur GLPI, il me demande encore une fenetre d'authentification
186530login.png
Lorsque je met mon login et mot de passe, j'arrive directement sur GLPI, mais j'ai quand même cette fenetre d'authentification qui s'affiche avant de m'identifier automatiquement... Comment faire???

Last edited by fab-6z (2014-04-15 15:22:56)

Offline

#2 2014-04-14 16:31:36

fab-6z
Guest
Registered: 2014-04-03
Posts: 24

Re: Authentification SSO

Personne ?

Last edited by fab-6z (2014-04-15 15:23:21)

Offline

#3 2014-04-16 10:44:16

EmpereurZorg
Guest
From: ORLEANS
Registered: 2005-12-31
Posts: 595

Re: Authentification SSO


Version GLPI : 0.85.2 + Plug'in FusionInventory 0.85+1.1 + Agents 2.3.15
Plateforme : Debian 7, Apache 2.2.22, PHP 5.4.39
Navigateur : Firefox 38 / Chrome occasionel

Offline

#4 2014-04-16 10:51:50

fab-6z
Guest
Registered: 2014-04-03
Posts: 24

Re: Authentification SSO

Je comprend pas trop ta question? Pourquoi NTLM sachant que je suis en AuthType SSPI?

Offline

#5 2014-04-18 08:51:49

fab-6z
Guest
Registered: 2014-04-03
Posts: 24

Re: Authentification SSO

Personne d'autre? J'ai l'impression que mon REMOTE_USER ne vient pas chercher mon login pour s'authentifier, d'ou la fenetre d'authentification qui apparait...

Offline

#6 2014-06-02 16:35:04

berserker
Guest
From: Toulouse
Registered: 2009-09-15
Posts: 156

Re: Authentification SSO

Déjà essayez de créer un fichier php qui fasse un echo de la variable REMOTE USER (google a plein d'exemples)

Ca vous indiquera si cela vient de GLPI ou d'ailleurs !


GLPI : 0.90.5 - OCS : 2.1.2
Plateforme : Windows Server 2008R2 Standard Edition Service Pack 1
Apache/2.2.31 (Win32) mod_ssl/2.2.31 OpenSSL/1.0.1p PHP/5.4.45 mod_perl/2.0.8 Perl/v5.16.3 ()
MySQL: 5.7.10-log

Offline

#7 2017-05-31 13:52:29

DomesPharma
Guest
Registered: 2017-05-31
Posts: 1

Re: Authentification SSO

Bonjour,

Je déterre ce vieux post puisque j'ai exactement le même soucis : le paramétrage semble fonctionner mais j'ai tout de même la fenêtre Windows d'authentification qui s'affiche.
Le serveur est un Windows 2012 en Processeur 64. Un XAMPP avec Apache 2.4 et ma version GLPI est la toute dernière 9.1.3

Est-ce que quelqu'un aurait une idée pour corriger ce problème svp ?

Merci d'avance !
---
Edit :
Je viens de voir que c'était mon navigateur Chrome qui posait soucis : cela fonctionne correctement avec Firefox en effectuant le petit paramétrage indiqué par fab à cette adresse : http://forum.glpi-project.org/viewtopic.php?id=33461

Last edited by DomesPharma (2017-06-02 11:03:46)

Offline

#8 2017-07-17 13:34:32

Tube
Guest
Registered: 2016-06-07
Posts: 9

Re: Authentification SSO

Bonjour,

je vais vous balancer une réponse assez brut. Mais elle m'a déjà sauvé. (je l'ai trouvé sur ce forum et sur un autre source en bas)


Les réglages apportés dans GLPI via l’outil :
Configuration -> Authentification -> Autres méthode d’authentification
Champs de stockage de l'identifiant dans la requete HTTP : REMOTE_USER
Supprimer le domaine des identifiants de la forme [email protected] : OUI

Il y a aussi eu un réglage au niveau du serveur APACHE. Il a fallu télécharger des modules complémentaires :

1. Télécharger le module mod_authnz_sspi.so x84 :
https://www.apachehaus.net/modules/mod_authnz_sspi/

2. Extraire le module et le copier dans le dossier des modules Apache

3. Ajouter dans le fichier httpd.conf la ligne suivante :

LoadModule authnz_sspi_module modules/mod_authnz_sspi.so

4. Décommenter dans le fichier httpd.conf les lignes suivantes :
LoadModule authn_core_module modules/mod_authn_core.so
LoadModule authz_core_module modules/mod_authz_core.so


5. Dans httpd-vhosts.conf ou autre selon la configuration Apache mise en place, modifier le « directory » GLPI pour intégrer l'authentification SSPI :

<Directory "C:/Program Files (x86)/Apache Software Foundation/Apache24/htdocs/glpi">
  Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
  AllowOverride FileInfo AuthConfig Limit
  <IfModule authnz_sspi_module>
      AuthName "Accès par SSO"
      AuthType SSPI
      SSPIAuth On
      SSPIAuthoritative On
      SSPIOfferBasic On
      # Should you need to force the login prompt, uncomment the next line
      #SSPIBasicPreferred On
      SSPIOfferSSPI On
      SSPIOmitDomain On
      require valid-sspi-user
     require user "NT AUTHORITY\ANONYMOUS LOGON" denied
  </IfModule>
</Directory>

6. Dans httpd.conf rajouter l’exclusion suivante :

<Location "/glpi/plugins/fusioninventory/">
  Satisfy Any
  Options FollowSymLinks
</Location>


Ps:  Si toujours un soucis penser à augmenter les variables memory dans php.ini (vue sur des forums)
Source : http://forum.glpi-project.org/viewtopic.php?id=33461 & http://forum.fusioninventory.org/viewtopic.php?id=1185

Offline

Board footer

Powered by FluxBB