You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-04-04 14:29:52

andrew.k2
Guest
From: Latvia
Registered: 2014-05-07
Posts: 57

Dashboard PHP Warning

Hello,

Maybe somebody can help me?

2017-04-04 13:26:39 [[email protected]]
  *** PHP Notice(8): Undefined variable: udisk
  Backtrace :
  plugins/dashboard/front/sh/df.php:74               
  plugins/dashboard/front/main.php:469               include()
2017-04-04 13:26:39 [[email protected]]
  *** PHP Notice(8): Undefined variable: udisk
  Backtrace :
  plugins/dashboard/front/sh/df.php:76               
  plugins/dashboard/front/main.php:469               include()
2017-04-04 13:26:39 [[email protected]]
  *** PHP Notice(8): Undefined variable: udisk
  Backtrace :
  plugins/dashboard/front/sh/df.php:78               
  plugins/dashboard/front/main.php:469               include()
2017-04-04 13:26:39 [[email protected]]
  *** PHP Notice(8): Undefined variable: udisk
  Backtrace :
  plugins/dashboard/front/sh/df.php:80               
  plugins/dashboard/front/main.php:469               include()
2017-04-04 13:26:39 [[email protected]]
  *** PHP Notice(8): Undefined variable: usedd
  Backtrace :
  plugins/dashboard/front/main.php:477               
2017-04-04 13:26:39 [[email protected]]
  *** PHP Notice(8): Undefined variable: totald
  Backtrace :
  plugins/dashboard/front/main.php:479               
2017-04-04 13:26:39 [[email protected]]
  *** PHP Notice(8): Undefined variable: titled
  Backtrace :
  plugins/dashboard/front/main.php:480               
2017-04-04 13:26:39 [[email protected]]
  *** PHP Notice(8): Undefined variable: udisk
  Backtrace :
  plugins/dashboard/front/main.php:481               
2017-04-04 13:26:39 [[email protected]]
  *** PHP Warning(2): file_get_contents(/var/www/html/files/_sessions/sess_4n0tn02spsm4c1h7n38i8hk0f5): failed to open stream: Permission denied
  Backtrace :
  :                                                  
  plugins/dashboard/front/main.php:766               file_get_contents()
2017-04-04 13:26:39 [[email protected]]
  *** PHP Warning(2): file_get_contents(/var/www/html/files/_sessions/sess_u54k4q8mfda10e8plar5865ie7): failed to open stream: Permission denied
  Backtrace :
  :                                                  
  plugins/dashboard/front/main.php:766               file_get_contents()
2017-04-04 13:26:39 [[email protected]]
  *** PHP Warning(2): file_get_contents(/var/www/html/files/_sessions/sess_vpc1v4l5mlet0eh6gqjju7d5e2): failed to open stream: Permission denied
  Backtrace :
  :                                                  
  plugins/dashboard/front/main.php:766               file_get_contents()
2017-04-04 13:26:39 [[email protected]]
  *** PHP Warning(2): file_get_contents(/var/www/html/files/_sessions/sess_gi5aahr74oo07ct01q6g69nke4): failed to open stream: Permission denied
  Backtrace :
  :                                                  
  plugins/dashboard/front/main.php:766               file_get_contents()

GLPI 0.9.1.2;
Dashboard 0.8.2;
CantOS 6

/var/www/html/files/_sessions - 755 apache;
/var/www/html/plugins/dashboard - 755 apache;

Is it plugin bug or my fault with access or something else?

http://forum.glpi-project.org/viewtopic.php?id=156108 - this topic wasn't useful for me. sad

Last edited by andrew.k2 (2017-04-04 14:31:34)


[prod] - GLPI 9.1.2; [test] - GLPI 9.1.2

Offline

#2 2017-06-16 08:22:10

KKAdmin
Guest
From: Germany
Registered: 2010-03-05
Posts: 480

Re: Dashboard PHP Warning

Please try a newer plugin version. i think this error message is fixed.

Plugin is working for me but on debug mode i got also error messages

GLPI 9.1.4
Dashboard 0.8.2;
Ubuntu 14.04.5 LTS

2017-06-16 08:18:18 [[email protected]]
  *** PHP Notice(8): Undefined index: sel
  Backtrace :
  ...ns/dashboard/front/tickets/select_grupo.php:151


You can mark this threat as [resolved] in subject of your threat. (This is only available edit of the first post.) It is good for users who help others to quickly see which post is still open.
##############################################
GLPI 9.1.2 /Ubuntu 14.04.4 LTS
Apache/2.4.7 (Ubuntu) - PHP 5.5.9-1ubuntu4.16 - MySQL: 5.5.49-0ubuntu0.14.04.1

Offline

Board footer

Powered by FluxBB