1

Topic: Découverte réseau + Inventaire SNMP multi-sites FI0.85+1.1

Bonjour,

Je rencontre des difficultés à faire fonctionner la découverte réseau sur FusionInventory 0.85+1.1. La configuration du réseau de l'entreprise est éclatée en plusieurs site avec plusieurs sous-réseau. Une plage d'adresse dans chaque sous-réseau est réservée aux équipements réseau et c'est sur ces plages que je veux faire la découverte et l'inventaire.

Voici ce que j'ai fait pour faire la découverte :

- Créer les différentes plages IP avec l'affectation de la communauté SNMP.
- Création d'une tâche avec une plage horaire définie (durée de 3h pour une date fixée).
- Création d'un job pour la tâche avec utilisation de la fonctionnalité "Découverte réseau"
- Affectation de toutes les plages IP en cible.
- Affectation d'agents pour le job (un en 2.3.16 sous Windows XP et un en 2.3.15 sous Debian 8).

La découverte fonctionne sur une des plages, mais une fois terminée, le scan sur cette plage repasse en préparée durant la plage horaire et les autre scans des autres plages passent en erreur avec le message suivant : L'agent demande une configuration qui lui a déjà été envoyée par le serveur.

Pour la partie inventaire, j'ai fait la même démarche sauf que les infos de la tâche ne remonte pas (pas de visuel pour dire si elle est préparée ou non), mais j'ai pu constater que certains équipements de la plage IP qui a pu être scanné on bien été inventoriés.

J'ai monté un autre serveur sous GLPI 0.84.8 avec FI en version 0.84+3.5, tout fonctionne avec ces versions.

Est-ce qu'il y a une démarche particulière à faire ? Sachant que j'ai trouvé une "pseudo" solution en créant autant de tâches que de sites avec des horaires décalés, c'est trop lourd à faire dans le cas de l'entreprise.

2

Re: Découverte réseau + Inventaire SNMP multi-sites FI0.85+1.1

T'as le soucis du scan que de la première plage IP avec la version 2.3.16 de l'agent?

3

Re: Découverte réseau + Inventaire SNMP multi-sites FI0.85+1.1

Oui j'ai bien ce problème. Est ce que le fait que l'agent 2.3.16 soit sur un Windows change quelque chose ?

4

Re: Découverte réseau + Inventaire SNMP multi-sites FI0.85+1.1

Possible, j'ai eu un soucis avec ça sous windows, désactive l'inventaire du pc pour cet agent, ça devrait être un peu mieux

5

Re: Découverte réseau + Inventaire SNMP multi-sites FI0.85+1.1

Ok, merci pour l'info, je vais tester ça dans la journée

6

Re: Découverte réseau + Inventaire SNMP multi-sites FI0.85+1.1

Je viens d'effectuer quelques tests avec glpi 0.85.4 et FI 0.85+1.1 et voici ce que j'ai trouvé :

Découverte réseau :

OK avec agent 2.3.16 sous debian 8 et Ubuntu 14.04
NOK avec agent 2.3.15 sous debian 8
NOK avec agant 2.3.16 sous Windows XP 32 bits (avec et sans inventaire)

Inventaire réseau :

OK seulement avec agent 2.3.16 sous debian 8 mais affiché en erreur et même non planifié dans le monitoring alors que j'ai bien récupéré toutes les infos.

7

Re: Découverte réseau + Inventaire SNMP multi-sites FI0.85+1.1

Bonjour,

Je reviens avec du retard avec une autre question :

J'ai configuré l'inventaire sur les plages IP de plusieurs sites, quand je regarde ensuite le monitoring du job, il me met d'abord les plages IP en erreur et en dessous les équipements qui ont été découvert par la tâche crée pour faire la découverte avec l'état OK.

Je voudrais donc savoir quel est la configuration à faire pour faire l'inventaire SNMP sur les équipements présents dans les plages IP, sachant que j'en ai une 40 à scanner.

La config est faite sur 2 serveurs GLPI: Un en 0.85.4 avec FI 0.85+1.3 l'autre sur GLPI 0.90 avec FI 0.90+1.0

Merci d'avance.

8

Re: Découverte réseau + Inventaire SNMP multi-sites FI0.85+1.1

Bonjour,

Je rebondis sur ce sujet car j'ai le même souci.

Le serveur GLPI 0.90.1 FI 0.90+1.0 sur un debian 8.
La liste des agents installés sur le serveur :
INVENTORY : v2.3.10.1
NETWORKDISCOVERY : 2.2.0
NETWORKINVENTORY : 2.2.0

J'ai une tâche découverte réseau avec plusieurs jobs pour plusieurs plages IP, il n'y a que le premier job qui s'exécute et les autres jobs restent en "Démarré" avec le message suivant : L'agent demande une configuration qui lui a déjà été envoyée par le serveur.

Pareil pour une tâche SNMP avec 2 jobs, seul le premier se lance.

Pouvez-vous m'aider svp ?

9

Re: Découverte réseau + Inventaire SNMP multi-sites FI0.85+1.1

Il faut utiliser le plugin fusion en version plus récente et parail pour l'agent (au moins 2.3.16)