1

Topic: Erreur "Loading Failed" et "Sorry You can't access this file directly"

Bonjour,

Suite à la migration de notre glpi windows vers linux, nous avons remarqué ce genre de message d'erreur (très souvent dans l'utilisation des listes déroulantes dans les différents menu de GLPI)

http://img11.hostingpics.net/pics/162844loadingfailed.png

http://img11.hostingpics.net/thumbs/mini_451903sorryyoucantaccessfiledirectoryv2.png

Quelques informations vis à vis de notre infra :
Il s'agit d'un serveur en ubuntu 16.04.2 LTS
En serveur web : nginx 1.10.0 (version PHP 7.0.13)
GLPI est en version 9.1.1

Il y a quelques plugins qui ont installé. En désactivant tous les plugins pas de changement.

Sur un autre PC qui nous sert en test (mais avec xampp 5.6.30 sous windows / php 5.6.30) pas de soucis particulier lors de l'importation de base SQL. (que l'on fait habituellement par phpmyadmin en prenant soin d'augmenter la taille d'upload limite)

Est-il envisageable qu'il y ait un problème de droit au niveau de nos fichiers ?
Ou que l'importation de la base sql n'est pas été effectué correctement ? 
Ou qu'il y ait autre chose à prendre en compte (étant donné qu'il s'agit d'une migration windows vers Linux ? )


Merci d'avance

INFRA ACTUEL WINDOWS XAMPP
Glpi 9.1.1 & Ocs 2.1.2
Environnement Windows Server 2012 R2 / Apache 2.2.21 / PHP 5.4.37 Mysl 5.0.10
Plugin GLPI : OCS Inventory NG 1.2.1 / Gestion d'objet 0.85-1.2 / Rapports 1.10 / Plus de rapports 1.3.1 / Alertes supplémentaires 1.9.0 / Champs supplémentaire 1.4.5 Réservations 1.3.5

2

Re: Erreur "Loading Failed" et "Sorry You can't access this file directly"

bonjour,
quelle version de MySQL ?

dans le php.ini qu'avez vous comme memory_limit ?

Trouver la panne avant de réparer...
*GLPI 0.90.5+fusion90+1.0+behaviours0.90+reports+fields+appliances+pdf+badges+webservices PHP7.0 Mariadb10
*GLPI 9.1.2 (behaviours+DashBoard+fields+pdf)hebergé sur serveur mutualisé.

3 (edited by Aldareis 2017-02-15 16:59:59)

Re: Erreur "Loading Failed" et "Sorry You can't access this file directly"

Bonjour

Alors pour la partie mysl : mysql v 14.14 distrib 5.7.17 (à contrario sur notre infra windows xampp on est en version 5.0.10)
Et pour la partie memory_limit : 1024Mo

EDIT : je ne sais pas si ça peut aider, mais si j'active le mode DEBUG j'ai ce genre d'alerte :
Le mode strict de SQL n'est pas complètement activé, valeur recommandée pour le développement : STRICT_TRANS_TABLES,ERROR_FOR_DIVISION_BY_ZERO,NO_ZERO_DATE,NO_ZERO_IN_DATE,ONLY_FULL_GROUP_BY,NO_AUTO_
CREATE_USER

INFRA ACTUEL WINDOWS XAMPP
Glpi 9.1.1 & Ocs 2.1.2
Environnement Windows Server 2012 R2 / Apache 2.2.21 / PHP 5.4.37 Mysl 5.0.10
Plugin GLPI : OCS Inventory NG 1.2.1 / Gestion d'objet 0.85-1.2 / Rapports 1.10 / Plus de rapports 1.3.1 / Alertes supplémentaires 1.9.0 / Champs supplémentaire 1.4.5 Réservations 1.3.5

4

Re: Erreur "Loading Failed" et "Sorry You can't access this file directly"

Test similaire effectué sur infrastructure similaire avec une version vierge et toute neuve en version 9.1.2 même type de problème.

Savez vous si nginx est bien pris en charge par GLPI ?

INFRA ACTUEL WINDOWS XAMPP
Glpi 9.1.1 & Ocs 2.1.2
Environnement Windows Server 2012 R2 / Apache 2.2.21 / PHP 5.4.37 Mysl 5.0.10
Plugin GLPI : OCS Inventory NG 1.2.1 / Gestion d'objet 0.85-1.2 / Rapports 1.10 / Plus de rapports 1.3.1 / Alertes supplémentaires 1.9.0 / Champs supplémentaire 1.4.5 Réservations 1.3.5

5

Re: Erreur "Loading Failed" et "Sorry You can't access this file directly"

bonjour,

la réponse est là dans les prérequis :
https://github.com/glpi-project/glpi

glpi n'est pas compatible avec mysql 5.7

Trouver la panne avant de réparer...
*GLPI 0.90.5+fusion90+1.0+behaviours0.90+reports+fields+appliances+pdf+badges+webservices PHP7.0 Mariadb10
*GLPI 9.1.2 (behaviours+DashBoard+fields+pdf)hebergé sur serveur mutualisé.

6 (edited by Aldareis 2017-02-17 10:04:53)

Re: Erreur "Loading Failed" et "Sorry You can't access this file directly"

Ok merci pour l'info.

On a vu que Maria DB est pris en charge également.

Par contre du coup si on installe MariaDB ça enlèvera le composant mysql déja en place ? (la BDD mysql déja en place a déja des choses en production que nous ne pouvons pas enlever)

INFRA ACTUEL WINDOWS XAMPP
Glpi 9.1.1 & Ocs 2.1.2
Environnement Windows Server 2012 R2 / Apache 2.2.21 / PHP 5.4.37 Mysl 5.0.10
Plugin GLPI : OCS Inventory NG 1.2.1 / Gestion d'objet 0.85-1.2 / Rapports 1.10 / Plus de rapports 1.3.1 / Alertes supplémentaires 1.9.0 / Champs supplémentaire 1.4.5 Réservations 1.3.5

7

Re: Erreur "Loading Failed" et "Sorry You can't access this file directly"

lors de ma dernière migration, j'ai importé un dump de mysql dans mariadb sans problèmes.

Trouver la panne avant de réparer...
*GLPI 0.90.5+fusion90+1.0+behaviours0.90+reports+fields+appliances+pdf+badges+webservices PHP7.0 Mariadb10
*GLPI 9.1.2 (behaviours+DashBoard+fields+pdf)hebergé sur serveur mutualisé.

8

Re: Erreur "Loading Failed" et "Sorry You can't access this file directly"

Bonjour,

Je viens de migrer en version 9.1.2 et j'ai moi aussi les problème de "Loading Failed" sur les listes suivantes :

Gestion / durée de garantie
Gestion / durée d'amortissement
Port réseau / prise réseau
Connexions / Connecter à un ordinateur
Modèle de cartouche / seuil d'alerte
Consommables / Seuil d'alerte

Ces listes sont non modifiables et, à priori, ne s'appuient par sur une table.

Ce problème est bloquant car les données correspondantes ne sont pas modifiables.

J'ai monté un GLPI dans la même version avec une base vierge et sans activer aucun plugin.
La liste fonctionne lorsqu'on essaie de la "dérouler" à la toute première utilisation, puis le problème "Loading failed" apparaît dès la deuxième tentative pour persister ensuite.

Pour info, ma configuration  :
PHP 5.5.9 / Ubuntu Server 14.04.1 LTS / MySQL Server 5.0.11

Par avance, merci pour votre aide.

NANTES METROPOLE HABITAT
OS : Ubuntu Server 14.04 LTS - Apache 2.4.7 - Php : 5.5.9 - MySQL : 5.1.11 - GLPI : 0.90.3 - OCS Inventory : 2.2.1 - Graphviz 2.16-3

9

Re: Erreur "Loading Failed" et "Sorry You can't access this file directly"

bonjour,
@p.chauvier
qu'avez vous dans configuration> générale>configuration générale>Ne pas utiliser le moteur de recherche dans les intitulés si le nombre d'éléments est inférieur à :

avez vous essayé avec "Jamais" ?

Trouver la panne avant de réparer...
*GLPI 0.90.5+fusion90+1.0+behaviours0.90+reports+fields+appliances+pdf+badges+webservices PHP7.0 Mariadb10
*GLPI 9.1.2 (behaviours+DashBoard+fields+pdf)hebergé sur serveur mutualisé.