1

Topic: Performance Error Message

If i activate debug mode i got in Home- Setup -General - performance following error.

PHP Notice: Undefined index: num_hits in /var/www/glpi/inc/config.class.php at line 1558
PHP Notice: Undefined index: num_misses in /var/www/glpi/inc/config.class.php at line 1559
PHP Warning: Division by zero in /var/www/glpi/inc/config.class.php at line 1561
PHP opcode cache
The "Zend OPcache" extension is installed     7.0.3FE         Zend OPcache
Memory     63.95 MB / 64 MB   
100%
    Zend OPcache
Hits rate     6481 / 7310   
89%
    Zend OPcache
Out of memory restart     0        Zend OPcache
    Reset
User data cache
The "APCu" extension is installed     4.0.2         APCu
Memory     436.17 kB / 32 MB   
1%
    APCu
Hits rate     / 0   
0%
    APCu
    Reset
AJAX DEBUG    Display only tab for debug





Information about system installation and configuration

 
GLPI 9.1.1 (/glpi => /var/www/glpi)

Server

 
Operating system: Linux inventar01 3.13.0-85-generic #129-Ubuntu SMP Thu Mar 17 20:50:41 UTC 2016 i686
PHP 5.5.9-1ubuntu4.20 apache2handler (Core, PDO, Phar, Reflection, SPL, SimpleXML, Zend OPcache, apache2handler, apc, apcu,
    bcmath, bz2, calendar, ctype, curl, date, dba, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imap, json,
    ldap, libxml, mbstring, mhash, mysql, mysqli, openssl, pcre, pdo_mysql, posix, readline, session, shmop, soap, sockets,
    standard, sysvmsg, sysvsem, sysvshm, tokenizer, wddx, xml, xmlreader, xmlwriter, zip, zlib)
Setup: max_execution_time="180" memory_limit="128M" post_max_size="8M" safe_mode="" session.save_handler="files"
    upload_max_filesize="50M" 
Software: Apache/2.4.7 (Ubuntu) (Apache/2.4.7 (Ubuntu) Server at ticket01 Port 80)
    Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Server Software: (Ubuntu)
    Server Version: 5.5.49-0ubuntu0.14.04.1
    Server SQL Mode: 
    Parameters: [email protected]/glpidb
    Host info: Localhost via UNIX socket
    
OK/var/www/glpi/config : OK
OK/var/www/glpi/files : OK
OK/var/www/glpi/files/_dumps : OK
OK/var/www/glpi/files/_sessions : OK
OK/var/www/glpi/files/_cron : OK
OK/var/www/glpi/files/_graphs : OK
OK/var/www/glpi/files/_lock : OK
OK/var/www/glpi/files/_plugins : OK
OK/var/www/glpi/files/_tmp : OK
OK/var/www/glpi/files/_rss : OK
OK/var/www/glpi/files/_uploads : OK
OK/var/www/glpi/files/_pictures : OK
OK/var/www/glpi/files/_log : OK
Web access to the files directory, should not be allowed
Check the .htaccess file and the web server configuration.

Libraries

 
htmLawed version 1.1.21 in (/var/www/glpi/lib/htmlawed)
phpCas version 1.3.4 in (/var/www/glpi/vendor/jasig/phpcas/source)
PHPMailer version 5.2.16 in (/var/www/glpi/vendor/phpmailer/phpmailer)
Zend Framework in (/var/www/glpi/vendor/zendframework/zend-loader/src)
zetacomponents/graph in (/var/www/glpi/vendor/zetacomponents/graph/src)
SimplePie version 1.4.1 in (/var/www/glpi/vendor/simplepie/simplepie/library)
TCPDF version 6.2.12 in (/var/www/glpi/vendor/tecnickcom/tcpdf)
michelf/php-markdown in (/var/www/glpi/vendor/michelf/php-markdown/Michelf)
true/punycode in (/var/www/glpi/vendor/true/punycode/src)
iacaml/autolink in (/var/www/glpi/vendor/iamcal/lib_autolink)
sabre/vobject in (/var/www/glpi/vendor/sabre/vobject/lib)



Plugins list

 
    news                 Name: Alarme                         Version: 0.90-1.3.1 State: Not activated
    barcode              Name: Barcode                        Version: 0.90+1.0   State: Not activated
    reports              Name: Berichte                       Version: 1.7.2      State: Not activated
    dashboard            Name: Dashboard                      Version: 0.7.7      State: Not activated
    datainjection        Name: File injection                 Version: 2.3.1      State: Not activated
    formcreator          Name: Formulare                      Version: 0.90-1.4-beta4 State: Enabled
    addressing           Name: IP Adressierung                Version: 2.3.0      State: Not activated
    pdf                  Name: PDF-Ausgabe                    Version: 1.0.2      State: Not activated
You can mark this threat as [resolved] in subject of your threat. (This is only available edit of the first post.) It is good for users who help others to quickly see which post is still open.
##############################################
GLPI 9.1.2 /Ubuntu 14.04.4 LTS
Apache/2.4.7 (Ubuntu) - PHP 5.5.9-1ubuntu4.16 - MySQL: 5.5.49-0ubuntu0.14.04.1

2

Re: Performance Error Message

What was your solution??

3

Re: Performance Error Message

I got no response and i have no solution.

You can mark this threat as [resolved] in subject of your threat. (This is only available edit of the first post.) It is good for users who help others to quickly see which post is still open.
##############################################
GLPI 9.1.2 /Ubuntu 14.04.4 LTS
Apache/2.4.7 (Ubuntu) - PHP 5.5.9-1ubuntu4.16 - MySQL: 5.5.49-0ubuntu0.14.04.1

4

Re: Performance Error Message

Ok, ok. I'm finding solution for this: "Web access to the files directory, should not be allowed
Check the .htaccess file and the web server configuration"

Regards

5

Re: Performance Error Message

Hi, friends

I have the same problem, does anyone have the solution?
It seems that this is becoming common, and it would be important that it be resolved.

6

Re: Performance Error Message

Install php and php-apcu

/etc/php/version/mods-available modify apcu.ini

apc.enabled=1
apc.shm_size=2M
apc.mmap_file_mask=/tmp/apc.XXXXXX

Same for opcache: install php-opcache add to file opcache.ini on same place it:

opcache.enable=1
opcache.enable_cli=1
opcache.memory_consumption=128
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=4000
opcache.revalidate_freq=60
opcache.fast_shutdown=1


Restart apache.

7

Re: Performance Error Message

Change message for apc_cache not activated: https://github.com/glpi-project/glpi/issues/1844

CentOS 6.5 - PHP 5.6 - PHP 7 - MySQL 5.6  + APC + memcached
GLPI 0.90.5 SVN - GLPI 9.1.3 SVN
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

8

Re: Performance Error Message

@yllen
thanks for acknowledging the bug.

@ecanton
i think this only change settings but i get the same error.

You can mark this threat as [resolved] in subject of your threat. (This is only available edit of the first post.) It is good for users who help others to quickly see which post is still open.
##############################################
GLPI 9.1.2 /Ubuntu 14.04.4 LTS
Apache/2.4.7 (Ubuntu) - PHP 5.5.9-1ubuntu4.16 - MySQL: 5.5.49-0ubuntu0.14.04.1