1

Topic: Prérequis GLPI : version de php ?

Bonjour,

Je viens de voir sur Github (https://github.com/glpi-project/glpi) que la version php nécessaire pour GLPI est php 5.5 ou supérieur.

Je voulais savoir ce qu'il en était.

En effet à l'heure actuelle je suis en :
php-5.4.16-36.3.el7_2.x86_64

Je travaille avec la version 0.90.3 de GLPI.

A partir de quel version de GLPI, la version 5.5 de php devient-elle nécessaire?

cordialement,

Prod : centos-release-7-2  | GLPI  0.90.3 | fusioninventory-for-glpi_0.90.1.3.tar.gz | fusioninventory-agent_windows-{x86|x64}_2.3.17
Rectorat de Caen

2

Re: Prérequis GLPI : version de php ?

5.5 sera la version nécessaire pour la 9.2.

La 9.1 fonctionne toujours avec PHP 5.4 (bien qu'une version supérieure puisse être bénéfique).

Pour CentOS 6 ou 7, pas de soucis, puisque

1/ PHP 5.6 ou 7.0 sont disponibles en SCL (Software Collections) dans le dépôt centos-scl (équivalent au canal RHSCL pour les utilisateurs de RHEL).

2/ il existe des dépôts tiers fournissant les versions récentes (voir ma signature)

Dév. Fedora 25 - PHP 5.4/5.5/5.6/7.0/7.1 - MariaDB 10.1 - GLPI master
Certifié ITILv3 - RPM pour Fedora, RHEL et CentOS sur https://blog.remirepo.net/

3

Re: Prérequis GLPI : version de php ?

Bonjour,

Et merci pour ta réponse.

Je vais donc commencer à regarder pour l'installation de php 5.5.

cordialement,

Prod : centos-release-7-2  | GLPI  0.90.3 | fusioninventory-for-glpi_0.90.1.3.tar.gz | fusioninventory-agent_windows-{x86|x64}_2.3.17
Rectorat de Caen

4

Re: Prérequis GLPI : version de php ?

> Je vais donc commencer à regarder pour l'installation de php 5.5.

Regardes plutôt PHP 5.6 wink   (la 5.5 a déjà dépassée sa fin de vie).

Dév. Fedora 25 - PHP 5.4/5.5/5.6/7.0/7.1 - MariaDB 10.1 - GLPI master
Certifié ITILv3 - RPM pour Fedora, RHEL et CentOS sur https://blog.remirepo.net/

5

Re: Prérequis GLPI : version de php ?

Bonjour,

Je voulais savoir si GLPI 0.90.3 fonctionne avec php 5.5 ( voir php 5.6 cf remarque de remi concernant la fin de vie de php 5.5)

En effet je voudrais faire une instance de test pour GLPI 9.2 sur le même serveur que mon GLPI 0.90.3.

Donc si GLPI 0.90.3 fonctionne avec les versions récentes de php, je n'aurai pas besoin de faire cohabiter plusieurs version de php.

cordialement,

Prod : centos-release-7-2  | GLPI  0.90.3 | fusioninventory-for-glpi_0.90.1.3.tar.gz | fusioninventory-agent_windows-{x86|x64}_2.3.17
Rectorat de Caen

6

Re: Prérequis GLPI : version de php ?

PHP 7 marche aussi très bien, autant se tourner vers le futur smile

- SoluTek.fr -
GLPI 9.1.1
Apache 2.4.17 / PHP 5.6.21