Topic: Update failure - 0.83.91 -> 0.84


I'm performing a chain of updates (waaaay behind), and have updated from 0.83.6 to 0.83.91 with no problems.
I can't successfully update to 0.84 though, and can't find anyone else with my problem.
Database was exported from mysql on Windows Server 2008 R2.
Database imported into mysql on XAMPP on Mac OS X.
Downloaded fresh 0.83.6 install, connected to database fine. (I did copy the glpi folder from the 2008 server, but it seemed to have done something screwy with the quote marks in the php files, a fresh download seemed easier than cleaning the mess up).
All updates being performed using Firefox on OS X.
Sequentially downloaded updates, updated database with no errors up to 0.83.91.

Update to 0.84 results in:

0.84 multiple alter in glpi_monitors - Error during the database query: ALTER TABLE `glpi_monitors` ADD `is_dynamic` TINYINT(1) NOT NULL DEFAULT '0' - Error is Table 'glpi.glpi_monitors' doesn't exist

At that point the update stops.

I've deleted the whole lot, started the entire process again, and face the same issue each time.

I don't know where to go from here, so any advice would be very helpful.



Re: Update failure - 0.83.91 -> 0.84

I've got some more info that may be important.
On a hunch I reverted back to 0.83.6 (by deletting everything including the database, and starting again with the import), and went to the Monitors section of Inventory.
There were no monitors present. When I clicked the + button, I got a the usual GLPI header with menus, and the usual footer, but nothing in between.
There seems to be something wrong right from the start. Everything else works except for the monitors section.

Any advice on how to recover from this situation?



Re: Update failure - 0.83.91 -> 0.84

Ok, kinda solved it I think. Not idea, and I don't know what caused the problem, but for anyone else facing a similar problem.
I created a NEW glpi installation, exported the SQL to create the missing table, and imported that into my existing database. From that point on the update worked fine.