1

Topic: Numéro de version plugin visible dans http://plugins.glpi-project.org

(Je ne sais pas si c'est trivial à traiter ou juste chiant alors je pose la question)

Soit un GLPI avec un certain nombre de plugins, sur la page setup.plugins.php j'ai la liste des plugins avec leur numéro de version.

Si je vais sur le site http://plugins.glpi-project.org le numéro de version de chaque plugin n'est pas visible. Or, si cétait le cas, cela permettrait de chercher rapidement si des nouvelles versions des plugins ont été publiées.

(Je sais, on peut aller sur la forge et suivre les flux RSS de chaque plugin, mais c'est pas la même chose)

Organize your helpdesk!

2

Re: Numéro de version plugin visible dans http://plugins.glpi-project.org

Bonjour,

Utilisant aussi de plus en plus de plugins, je pense que cela pourrait être intéressant de filtrer la liste des plugins en fonction de la version utilisée de GLPI (un peu a la manière du site Drupal.org avec ses modules)
Cela facilitera aussi la préparation des montées en version.

Production : GLPI 0.90.1 - Debian 8 - Apache 2.4 - PHP 5.6 - MySQL 5.5 - OCS NG 2.0
Plugins : Applications Web, Bases de données, Comportements, Comptes, Imports Fabricants, Impressions PDF, Purge historique, Simcard, Formulaires, Generic objects

3

Re: Numéro de version plugin visible dans http://plugins.glpi-project.org

Ben, dans la zone de recherche, tu tapes 0.80 et t'auras cette liste....

Dév. Fedora 25 - PHP 5.4/5.5/5.6/7.0/7.1 - MariaDB 10.1 - GLPI master
Certifié ITILv3 - RPM pour Fedora, RHEL et CentOS sur https://blog.remirepo.net/

4

Re: Numéro de version plugin visible dans http://plugins.glpi-project.org

la liste des plugins compatibles mais pas leur numéro de version.
Par exemple tu es en 0.80 avec la plugin machin en version 1.3.2 et ka version 1.5 du plugin pour la 0.80 est sortie mais tu ne peut pas le voir... Sur le catalogue en tout cas.

MoYo - Julien Dombre - Association INDEPNET
Contribute to GLPI :    Support     Contribute     References     Freshmeat

5

Re: Numéro de version plugin visible dans http://plugins.glpi-project.org

Bonsoir,

Je reviens sur ce topic.
La clé de recherche 0.80 ne suffit plus
Quand on rentre dans le suivi précis des plugins, certains ont des versions pour GLPI de 0.80.0 à 0.80.2 puis une autre >= 0.80.3 et <0.81 ou 0.83
Ce n'est pas un reproche mais un fait que je comprends tres bien.
Serait il possible a partir des informations de la forge de les regrouper dans une matrice de compatibilité ?
Il est vrai que cela sera peut être un peu indigeste vu le nombre de plugins et de versions GLPI.Mais si l'on peut ensuite filtrer sur le champ version GLPI ce sera tres productif

Production : GLPI 0.90.1 - Debian 8 - Apache 2.4 - PHP 5.6 - MySQL 5.5 - OCS NG 2.0
Plugins : Applications Web, Bases de données, Comportements, Comptes, Imports Fabricants, Impressions PDF, Purge historique, Simcard, Formulaires, Generic objects