You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-01-22 18:05:16

maxdecimus
Guest
Registered: 2018-01-22
Posts: 3

Problème d'import d'utilisateurs - erreur dans massiveaction.class.php

Bonjour,

Lorsque je veux importer des utilisateurs ad depuis le menu administration puis bouton liaison annuaire LDAP.

Je fais ensuite importation de nouveaux utilisateurs, la recherche me donne des nouveaux utilisateurs à importer.

Je coche donc les cases à cocher devant le nom des utilisateurs et quand je clique sur le bouton action j'ai le message suivant en mode débug : PHP Warning: Invalid argument supplied for foreach() in /var/www/glpi/inc/massiveaction.class.php at line 119

Le nom de mon utilisateur est composé d'un caractère ' (exemple : Jean Du'Pont), est-ce que le plantage du fichier PHP viendrait de là ? et donc je ne peux rien importer.

Merci pour votre aide.

Offline

#2 2018-01-22 18:33:40

kurasul
Guest
Registered: 2017-12-20
Posts: 151

Re: Problème d'import d'utilisateurs - erreur dans massiveaction.class.php

Bonjour maxdecimus
peux tu deja nous donne ton envrionnement ?
as tu regarder dans les log les erreur qui remonte ?
cdt


Kurasul // IT Manager  ============  https://discord.gg/qgDXNwS
OS + plugins: Ubuntu 16.04 // GLPI 9.2.1 // Php 7.0 // Sql + phpmyadmin // LDAP //
Fusion Inventory 9.2+1.0 //Cartographie 4.4.0 // Dashboard 1.4.0 // Gestion de baies 1.8.0 // Comptes 2.3.0 // Impression PDF
Imports fabricants 2.0.0 // Liste des taches 1.2.0 // Plus de rapports 1.4.0 // Arrêté du parc 2.4.0

Offline

#3 2018-01-23 10:42:06

maxdecimus
Guest
Registered: 2018-01-22
Posts: 3

Re: Problème d'import d'utilisateurs - erreur dans massiveaction.class.php

Bonjour,

Voici les infos demandées ci-dessous.

Environnement:
Linux 3.16.0-5 Debian 3.16.51-3
Apache : 2.4.10
lib-apache-mod-php5 : 5.6.30
php5-mysql : 5.3.60
glpi 9.2.1

Message d'erreur dans /var/www/glpi/files/_log/php-errors.log

2018-01-23 09:31:28
  *** PHP Warning(2): Invalid argument supplied for foreach()
  Backtrace :
  inc/massiveaction.class.php:119
  ajax/massiveaction.php:46                          MassiveAction->__construct()

Merci.

Last edited by maxdecimus (2018-01-23 10:42:55)

Offline

#4 2018-01-23 11:01:35

kurasul
Guest
Registered: 2017-12-20
Posts: 151

Re: Problème d'import d'utilisateurs - erreur dans massiveaction.class.php

dans authentification ==> annuaire ldap as tu bien renseigne la ligne de filtre

(&(objectClass=user)(objectCategory=person)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))

as tu essaye d'importer quelque personnes sans caractere specifique comme ton "jean du'pont"
cdt


Kurasul // IT Manager  ============  https://discord.gg/qgDXNwS
OS + plugins: Ubuntu 16.04 // GLPI 9.2.1 // Php 7.0 // Sql + phpmyadmin // LDAP //
Fusion Inventory 9.2+1.0 //Cartographie 4.4.0 // Dashboard 1.4.0 // Gestion de baies 1.8.0 // Comptes 2.3.0 // Impression PDF
Imports fabricants 2.0.0 // Liste des taches 1.2.0 // Plus de rapports 1.4.0 // Arrêté du parc 2.4.0

Offline

#5 2018-01-23 11:06:35

maxdecimus
Guest
Registered: 2018-01-22
Posts: 3

Re: Problème d'import d'utilisateurs - erreur dans massiveaction.class.php

Oui la ligne de filtre est la même.

J'ai essayé en cochant d'autres utilisateurs sans caractère spécifique et j'ai le même message d'erreur.

Offline

Board footer

Powered by FluxBB