You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-01-10 11:46:26

Snowthecrow
Guest
Registered: 2018-01-10
Posts: 8

Installation GLPI 9.2.1 sous Linux

Bonjour à tous ..

Actuellement en stage dans une entreprise de comptabilité et audit, mon responsable m'a demandé de mettre à jour notre version de Glpi.
Après m'être aidé des tuto sur le web et avoir surmonté mon problème de permission (tout en ligne de commande), l'installation est presque terminé. Sauf que lors des phases de test de Glpi sur la page du navigateur, on m'indique que l'extension curl est manquante.

Quelqu'un peut-il m'aider svp, je n'ai strictement aucune idée / doc / ... de comment résoudre ça.
Resultat test

Amicalement, Snow.

Offline

#2 2018-01-10 11:59:22

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 3,567

Re: Installation GLPI 9.2.1 sous Linux

il manque une extension sur le serveur :
quel serveur ? quelles versions de php, mysql ?
avez vous vérifié les prérequis ? :https://github.com/glpi-project/glpi

Prerequisites

    A web server (Apache, Nginx, IIS, etc.)

    MariaDB (or MySQL < 5.7)

    PHP 5.6 or higher

    Mandatory PHP extensions:
        json
        mbstring
        mysqli
        session
        gd (picture generation)
        curl (CAS authentication)

    Recommended PHP extensions (to enable optional features)
        domxml (CAS authentication)
        imap (mail collector and users authentication)
        ldap (users authentication)
        openssl (encrypted communication)


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+webservices PHP7.0 Mariadb10
*GLPI 9.2.1(behaviours1.5.2+fusion9.2+1.0+applicatifs2.3.0+dashboard 0.8.9)hebergé sur serveur mutualisé.

Offline

#3 2018-01-10 12:29:27

Snowthecrow
Guest
Registered: 2018-01-10
Posts: 8

Re: Installation GLPI 9.2.1 sous Linux

Salut LaDenrée,

Php
UeXFt029

Merci pour ton aide, j'y vais à taton là, c'est les seules infos que j'ai.
j'ai un phpipam et phpipam-1.3.tar qui trainent dans la racine. Il ne dois pas être à jours.

Offline

#4 2018-01-10 12:44:08

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 3,567

Re: Installation GLPI 9.2.1 sous Linux

c'est un sujet serveur, pas vraiment spécifique à GLPI.
il faut activer curl sur le debian
voir ici par exemple https://www.developpez.net/forums/d1481 … us-debian/

il y a probablement d'autres membres plus spécialiste que moi dans ce domaine, je ne peux pas aider beaucoup plus .

/!\ NE PAS OUBLIER les sauvegardes avant une telle manip et s'assurer qu'on sait les restaurer /!\


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+webservices PHP7.0 Mariadb10
*GLPI 9.2.1(behaviours1.5.2+fusion9.2+1.0+applicatifs2.3.0+dashboard 0.8.9)hebergé sur serveur mutualisé.

Offline

#5 2018-01-10 13:06:05

Snowthecrow
Guest
Registered: 2018-01-10
Posts: 8

Re: Installation GLPI 9.2.1 sous Linux

Merci à toi l'ami ..

Problem solved. grâce à ton topic.

solution :
apt-get update (sauf si vous vous savez à jour, mais dans le doute je fait)
apt-get install php5-curl
apt-get update
/etc/init.d/apache2 restart

Maintenant il reste imap / APCu et xmlrpc


edit : apt-get install php5-ipam smile
        apt-get install php5-APCu
        apt-get install php5-xmlrcp

Suite à cela, n'oubliez pas de faire un update puis de restart le service apache2.
Cliquer sur "ressayer" sur votre page web qui est à l'étape 0 de votre installation Glpi et tout roule !

Valable pour Glpi 9.2.1

Last edited by Snowthecrow (2018-01-10 15:54:19)

Offline

Board footer

Powered by FluxBB