You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-09-05 17:48:44

eNty
Guest
Registered: 2015-02-16
Posts: 7

Champs Obligatoires via gabarit

Bonjour à tous, 

Je me permets de poster ce sujet car je pense être confronté à un souci lié aux champs obligatoires via un gabarit de ticket, depuis l'interface web de GLPI.

Je soupçonne un problème au niveau de l'assistance. J'ai créé un gabarit de ticket dans lequel j'ai forcé trois champs obligatoires (Lieux et Catégorie qui sont des listes déroulantes, et Description un champ texte).
Lors de l’accès à la page de création de l'incident, je ne visualise pas d’étoile rouge qui indique qu'un champ est obligatoire. Si je vais dans la liste déroulante Catégorie (ou Lieux peu importe)  pour valider mon choix, la page semble se rafraîchir et à partir de ce moment la les étoiles apparaissent à coté des trois champs obligatoires. Je visualise ce fait en mode simplifié ou normal, et sur les différents browser actuels (FF / Chrome / Edge / IE).

A noter, que si nous n'allons pas dans les champs Lieux et Catégorie, le ticket se créés sans les champs obligatoires.

Voici trois screen qui devrait être plus parlant que ce récit.

fkJJ4r.png

rqB1Nr.png

blbs2v.png

Informations :


Version : GLPI 0.90.3

Plugins :

        behaviors            Name: Comportements                  Version: 0.90       State: Enabled
    formcreator          Name: Formulaires                    Version: 0.90-1.2.5 State: Enabled
    moreticket           Name: More ticket                    Version: 1.2.1      State: Not activated
    reports              Name: Rapports                       Version: 1.9.0      State: Not activated
    dashboard            Name: Tableau de bord                Version: 0.6.8      State: Enabled

Informations Serveur :
Operating system: Linux GLPI90 3.2.0-4-amd64 #1 SMP Debian 3.2.68-1+deb7u5 x86_64
PHP 5.4.45-0+deb7u1 apache2handler (Core, PDO, Phar, Reflection, SPL, SimpleXML, apache2handler, bcmath, bz2, calendar, ctype,
    date, dba, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imap, json, libxml, mbstring, mcrypt, mhash, mysql,
    mysqli, openssl, pcre, pdo_mysql, posix, session, shmop, soap, sockets, standard, sysvmsg, sysvsem, sysvshm, tokenizer, wddx,
    xml, xmlreader, xmlwriter, zip, zlib)
Setup: max_execution_time="30" memory_limit="128M" post_max_size="8M" safe_mode="" session.save_handler="files"
    upload_max_filesize="8M"
Software: Apache/2.2.22 (Debian) (Apache/2.2.22 (Debian) Server at *******)
    Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Server Software: (Debian)
    Server Version: 5.5.44-0+deb7u1
    Server SQL Mode:
    Parameters: [email protected]/GLPI90
    Host info: Localhost via UNIX socket
   
OK/opt/glpi/config : OK
OK/opt/glpi/files : OK
OK/opt/glpi/files/_dumps : OK
OK/opt/glpi/files/_sessions : OK
OK/opt/glpi/files/_cron : OK
OK/opt/glpi/files/_graphs : OK
OK/opt/glpi/files/_lock : OK
OK/opt/glpi/files/_plugins : OK
OK/opt/glpi/files/_tmp : OK
OK/opt/glpi/files/_rss : OK
OK/opt/glpi/files/_uploads : OK
OK/opt/glpi/files/_pictures : OK
OK/opt/glpi/files/_log : OK
Web access to files directory is protectedWeb access to files directory is protected : OK

Je ne sais pas si j'ai oublié une information, mais n'hesitez pas si il vous manque quelque chose.

D'avance un grand merci à vous wink

Offline

#2 2017-09-06 12:02:05

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,879

Re: Champs Obligatoires via gabarit

Bon on va commencer par le début.
A qui avez-vous affecté le gabarit créé ? d'après vos copies d'écran il semble affecté à une catégorie.

Si vous voulez que ce gabarit soit utilisé dès la création du ticket pour tout le monde, il faut l'affecter à l'entité.


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#3 2017-09-06 21:12:53

eNty
Guest
Registered: 2015-02-16
Posts: 7

Re: Champs Obligatoires via gabarit

Bonsoir  yllen,

Merci pour votre réponse.

Au niveau de l'administration de l'entité en question (Accueil>Administration>Entités), dans le menu "Assistance" Le gabarit de Ticket est bien le gabarit qui contient les champs obligatoires.

Votre réflexion m'a fait pensé à aller voir au niveau de la catégorie si le gabarit n'était pas différent, mais c'est le même qui est attribué à la catégorie (Accueil>Configuration>Intitulés>Catégories de Tickets) les gabarits pour demande et incident sont corrects.

Est ce que l'attribution du gabarit via l'entité et via la catégorie de tickets générerait un problème ?

Merci

Offline

#4 2017-09-13 19:59:10

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,879

Re: Champs Obligatoires via gabarit

Regardez si vous n'auriez pas en plus un gabarit affecté au profil


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#5 2017-09-20 14:18:06

eNty
Guest
Registered: 2015-02-16
Posts: 7

Re: Champs Obligatoires via gabarit

Bonjour Yllen,

Il n'y avait pas de gabarit affecté sur le profil utilisé pour la création de ticket.
Je pense avoir trouvé l'origine de mon souci, et je ne sais pas dire si le comportement est normal ou non.
Dans mon gabarit de ticket j'avais défini un champ obligatoire "Catégorie", mais j'avais également prédéfini ce champ dans le même gabarit. En supprimant le champ prédéfinie, je retrouve directement les étoiles rouges en  arrivant sur la page de création de ticket, signe du champ obligatoire.

Je vous remercie de votre aide et du temps que vous consacrez à GLPI

Offline

#6 2017-09-25 19:25:40

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,879

Re: Champs Obligatoires via gabarit

Merci du retour. Je clos


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

Board footer

Powered by FluxBB