You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-06-26 14:04:42

Eric26
Guest
From: Valence (26)
Registered: 2007-02-17
Posts: 359
Website

[FormCreator 2.5.1] Notice et warning Php

Bonjour,

Nous avons installé le plugin FormCreator 2.5.1 "from scratch" sur notre GLPI 9.1.4. Nous avons créé 4 formulaires qui fonctionnent parfaitement mais quand nous nous rendons dans la configuration d'un de ces formulaires, section "Formulaire saisi", nous obtenons le message suivant, qu'il y ait des formulaires saisis ou pas :
PHP Notice: Undefined variable: options in ..\plugins\formcreator\inc\form_answer.class.php at line 250
PHP Warning: Invalid argument supplied for foreach() in ..\plugins\formcreator\inc\form_answer.class.php at line 250

Nous sommes en superAdmin et le mode débug est activé.


Amicalement,
Eric
-------------------------------------------------------------
Prod : GLPI 9.1.4 - Serveur IIS8.5 (w2012r2) - PHP 5.6.16 - MySql 5.7.11 -- Test : GLPI 9.1.4 - Serveur Apache 2.2.17 - PHP 5.6.16 - MySql 5.7.11

Offline

#2 2017-06-26 15:37:05

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,879

Re: [FormCreator 2.5.1] Notice et warning Php


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#3 2017-06-26 15:37:58

btry
Guest
Registered: 2015-10-01
Posts: 134

Re: [FormCreator 2.5.1] Notice et warning Php

Bonjour

Le bug est déjà corrigé dans la branche develop.

Offline

#4 2017-06-26 16:58:25

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,879

Re: [FormCreator 2.5.1] Notice et warning Php

T'es certain btry ?
Parce que pour faire ma PR je suis parti du fichier présent dans le dossier code - branche master- du github


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#5 2017-06-26 17:11:27

btry
Guest
Registered: 2015-10-01
Posts: 134

Re: [FormCreator 2.5.1] Notice et warning Php

Oui. mais il faut attendre la prochaine release pour que le correctif soit disponible.

Dans le cas contraire, il faut appliquer ce commit : https://github.com/pluginsGLPI/formcrea … c3e7275589

la branche master correspond à la dernière release; et tout le code non releasé est dans develop.

Pour info, je compte fournir une prochaine release dans environ 1 mois.

Offline

#6 2017-06-26 18:21:42

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,879

Re: [FormCreator 2.5.1] Notice et warning Php

D'où mon erreur. Pour moi la branche Master était la prochaine version....


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

Board footer

Powered by FluxBB