You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-06-19 18:30:24

yannix63
Guest
Registered: 2008-10-29
Posts: 165
Website

Mise à jour de 9.1.3 à 9.1.4

Bonjour à tous
Je suis avec GLPI 9.1.3 en prod qui tourne sur un debian (Debian GNU/Linux 7.11 (wheezy)) qui fonctionne pour les tickets, la réservation de matériel avec une synchro AD
J'ai commencé à regarder pour faire une mise à jour en 9.1.4 mais j'ai trois messages d'avertissement sur les extension Zend OPcache, APCu et xmlrpc.
Peut-être que ces messages était déjà là lors de la dernière mise à jour mais je n'y ai pas fait attention.

D'après ce que j'ai lu, cela permet d'optimiser le fonctionnement de GLPI, et comme j'ai de plus en plus de lenteur j’aimerai bien corriger ces message avant d'appliquer la mise à jour.

Est-ce que vous avez déja installé ses extension sous debian / php 5.4 ?
Merci à tous pour vos retours, explications et liens qui me permettrai d'avancer sur cette problématique

Last edited by yannix63 (2017-06-20 11:43:35)

Offline

#2 2017-06-20 10:47:33

yannix63
Guest
Registered: 2008-10-29
Posts: 165
Website

Re: Mise à jour de 9.1.3 à 9.1.4

Bonjour à tous
J'ai réussi à installé le module de cache opcode de PHP avec mon php 5.4
J'en profite pour faire un petit retour d'expérience au cas ou cela servirai à d'autres

J'ai suivi cette procédure sans faire la mise à jour vers php 5.5
https://phil.writesthisblog.com/installer-zend-opcache/
il y avait simplement un problème dans le chemin
Dans la doc c'est : /usr/lib/php5/20100525/opcache.so
et chez moi c'est /usr/lib/php5/20100525+xxx/opcache.so
et ça fonctionne


Concernant l'extension APCu, je pense qu'elle n'existe pas pour php 5.4 et que je serai obligé de passer en 5.5

D'autres retours d'expérience ????

Last edited by yannix63 (2017-06-20 11:32:51)

Offline

#3 2017-06-20 11:54:16

Remynshape
Guest
Registered: 2017-06-19
Posts: 21

Re: Mise à jour de 9.1.3 à 9.1.4

salut moi j'ai du installer APCu aussi quand j'ai mis à jours mon GLPI de 9.1.3 à 9.1.4 et j'ai utilisé cette procédure pour que le message sois validé par GLPI:

Apt-cache search APCu (permet de savoir ou se trouve APCu)
Apt-get install php5-APCu (une fois trouvé je l'installe )
A2ensite glpi.conf ( redémarre glpi)
/etc/init.d/apache2  restart ( redémare apache2)

une fois cela fait tout fonctionnera et si il vous reste d'autres messages faite de même avec les différents paquets manquant


Je suis stagiaire dans Geco et on m'appel : Rémy le Roi du GLPI ...

Offline

#4 2017-06-20 12:06:07

remi
GLPI-DEV
From: Champagne
Registered: 2007-04-28
Posts: 7,093
Website

Re: Mise à jour de 9.1.3 à 9.1.4

Le mieux est quand même de passer sur PHP 5.6 qui est la plus ancienne version maintenue de PHP, et qui sera la version minimum de PHP acceptée par la prochaine version de GLPI (9.2)

Pour info, opcache and APCu ne sont pas obligatoire, juste recommandée


Dév. Fedora 25 - PHP 5.4/5.5/5.6/7.0/7.1/7.2 - MariaDB 10.1 - GLPI master
Certifié ITILv3 - RPM pour Fedora, RHEL et CentOS sur https://blog.remirepo.net/

Offline

Board footer

Powered by FluxBB