You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-06-12 15:58:54

jreynaud40
Guest
Registered: 2009-05-27
Posts: 16

Migration GLPI 0.83.4 ->0.91 et OCS 2.0

Bonjour,

Nous avons une très vieille version de GLPI (0.83.4) et OCS (2.0) le tout sur un serveur XAMPP 1.7.7 (pas très jeune).

On a essayé pas mal de choses mais rien de concluant, toujours du souvent à la version de php nécessaire pour GLPI 0.91.

De plus a priori avec la dernière version de PHP, c'est le site OCS qui plante.


La question est : comment effectuer la migration de tout ce petit monde (si quelqu'un l'a déjà expérimenté) ?




Merci pour votre réponse

Jérôme

Offline

#2 2017-06-12 19:17:00

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,760

Re: Migration GLPI 0.83.4 ->0.91 et OCS 2.0

Sauf erreur de ma part, la version Xampp fournie avec OCS n'est pas compatible GLPI 9.1.
Il faut donc installer votre propre Xampp avant de faire les migrations


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#3 2017-06-14 10:51:27

jreynaud40
Guest
Registered: 2009-05-27
Posts: 16

Re: Migration GLPI 0.83.4 ->0.91 et OCS 2.0

Bonjour,

Je viens d'essayer de refaire complètement mon install.

Je suis passé sous IIS, j'ai mis PHP et MySQL et la 0.91.3 de GLPI puis réintégré mes données de l'ancienne base.

Ce matin, GLPI me refait un upgrade et bloque sur une mise à jour dont voici le détail :

Mise à jour

Connexion à la base de données réussie

Traitement en cours...

Mise à jour en 0.85.3
Traitement terminé. (0 seconde)
     
Mise à jour en 0.85.5
Traitement terminé. (0 seconde)

Mise à jour en 0.90
Traitement terminé. (0 seconde)
PHP Warning: A non-numeric value encountered in C:\test\glpi\install\update_0855_090.php at line 87


Que se passe t-il ?

Cordialement,

Jérôme REYNAUD

Offline

#4 2017-06-15 20:31:26

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,760

Re: Migration GLPI 0.83.4 ->0.91 et OCS 2.0

Cette ligne correspond à une suppression d'une valeur dans la table config et il n'y a pas de valeur numéric dans la commande.

Pouvez-vous me donner le contenu de la ligne 87 ddu fichier glpi/install/update_0885_090.php ?


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#5 2017-06-16 09:40:35

Pierre goudat
Guest
Registered: 2017-06-12
Posts: 34

Re: Migration GLPI 0.83.4 ->0.91 et OCS 2.0

Bonjour,

j'effectue également une migration de GLPI en ce moment. Voici les configs que j'ai utilisées et qui fonctionnent :



GLPI : 0.84 => 9.1.3
Wamp Serveur : 2.2 => 2.4
Apache : 2.2.21 => 2.4.4
PHP : 5.3.8 => 5.4.12
MySQL : 5.5.16 => 5.6.12

Ainsi je met d'abord à jour mes services (PHP, MySQL, Apache, etc) puis glpi

Offline

Board footer

Powered by FluxBB