You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-06-01 14:45:46

Atom
Guest
Registered: 2009-03-18
Posts: 5

User filtering by "group1 AND group2" not working

Hi all,

We have our users belonging to different groups/subgroups, with many of them belonging to more than one group.

If we filter the users by

groups is group1   OR   groups is group2

this works ok and shows us users belonging to group1 OR group2.

Now, if we filter by

groups is group1   AND   groups is group2

we get no results at all, even though of course there are user belonging to group1 AND group2.

Is this the expected behaviour or are we missing something?


GLPI 9.1.2

Last edited by Atom (2017-06-01 14:46:04)

Offline

#2 2017-06-01 19:32:19

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,789

Re: User filtering by "group1 AND group2" not working


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#3 2017-06-01 20:03:19

Atom
Guest
Registered: 2009-03-18
Posts: 5

Re: User filtering by "group1 AND group2" not working

Thanks Yllen. I was hesitating about opening an issue directly without further confirmation.

I'll follow this on  the github issue from now on.

Last edited by Atom (2017-06-01 20:17:01)

Offline

Board footer

Powered by FluxBB