You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-05-23 15:27:58

aw_lgr31
Guest
Registered: 2016-09-05
Posts: 9

Incompatibilité Collecteur de mail + plugin Champs suppl. (Fields)

Bonjour,

En mal avec la relève des mails via le collecteur de mail, j'ai dû debuger en pas à pas pour découvrir que la création du ticket correspondant à un mail, échouait quand le plugin Champs supplémentaires (fields) était activé, et que deux champs supplémentaires avaient été déclarés au niveau du Ticket.
La désactivation du plugin résoud systématiquement le problème, et ce sur plusieurs installations testées.

Pour préciser, c'est dans la méthode que cela se passe $track = new Ticket() de mailcollector.class.php, où on tombe en FAILED_INSERT.


                     } else { // New ticket
                        $track = new Ticket();
                        if ($track->add($tkt)) {
                           $delete_mail = self::ACCEPTED_FOLDER;
                        } else {
                           $error++;
                           $rejinput['reason'] = NotImportedEmail::FAILED_INSERT;
                           $rejected->add($rejinput);
                        }
                     }


Version GLPI : 0.90.1
Version plugin fields : 1.4.2

Offline

#2 2017-05-23 15:57:48

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 3,193

Re: Incompatibilité Collecteur de mail + plugin Champs suppl. (Fields)

bonjour,
je suis en 9.1.3 avec fields 1.3.1 et la creation des emails par mailgate se fait sans problèmes.


Trouver la panne avant de réparer...
*GLPI 0.90.5+fusion90+1.0+behaviours0.90+reports+fields+appliances+pdf+badges+webservices PHP7.0 Mariadb10
*GLPI 9.1.5 (behaviours+DashBoard+fields+pdf)hebergé sur serveur mutualisé.

Offline

#3 2017-05-23 16:02:31

aw_lgr31
Guest
Registered: 2016-09-05
Posts: 9

Re: Incompatibilité Collecteur de mail + plugin Champs suppl. (Fields)

Finalement je suis passé en version 1.4.5 de fields, et tout semble bien fonctionner désormais.

Offline

Board footer

Powered by FluxBB