1

Topic: glpi 9.1.3 - Base vide

Bonjour à tous, et désolé que mon premier message soit pour un souci d'installation.

Je suis sur une debian Jessie - PHP 5.6.30 - MySQL 5.5. J'ai téléchargé la dernière archive stable (glpi-9.1.3.tgz) et je tente l'installation (plusieurs fois, en nettoyant bien tout entre chaque tentative).
Lorsque j'arrive à l'étape d'initialisation de la base de données, le process me dit qu'il a bien fonctionné mais aucune table n'est créée.
J'ai donc tenté, une fois cette étape ratée pour la Xème fois, d'importer les tables via la console:

mysql -u glpi -p glpi < glpi-9.1.3-empty.sql

Les tables sont bien créées mais lorsque je vais sur glpi, un message me signale que je dois mettre à jour la base. Et lorsque je le fais, ça semble agir sauf que je retombe sur le message d'erreur.

Est-ce que je me fourvoie dans mon process ? Ou est-ce un bug ?

2

Re: glpi 9.1.3 - Base vide

Si GLPI vous indique que vous devez mettre à jour votre base, c'est que la version de celle-ci est inférieure à la version de vos pages.
Dans la table glpi_configs, quelle est la valeur du champ version ?
Dans glpi/config/define.php, quelle est la valeur de define("GLPI_VERSION",....) ?

CentOS 6.5 - PHP 5.6 - PHP 7 - MySQL 5.6  + APC + memcached
GLPI 0.90.5 SVN - GLPI 9.1.3 SVN
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

3

Re: glpi 9.1.3 - Base vide

En fait, le souci provenait de l'installation précédente (via apt-get sur le repository debian) qui se nettoyait mal malgré l'option de --purge.

Après en avoir supprimé toutes les traces à la main, j'ai réussi à bien installer une nouvelle version depuis l'archive.

Merci tout de même pour l'aide

4

Re: glpi 9.1.3 - Base vide

Merci du retour. Je clos

CentOS 6.5 - PHP 5.6 - PHP 7 - MySQL 5.6  + APC + memcached
GLPI 0.90.5 SVN - GLPI 9.1.3 SVN
Certifiée ITIL (ITV2F, ITILF, ITILOSA)