You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-03-23 15:29:57

eric.nicolas
Guest
Registered: 2017-03-23
Posts: 1

Lenteur suite à l'activation du plugin "Champs supplémentaires"

Bonjour à tous,


Depuis environ 1 mois, nous utilisons GLPI en production.
Quelques précisions de config :
- Machine virtuelle (VMWARE) Windows 2012 R2, 4 Go RAM, 8 cpu
- Wamp server 3.0.6 64bit
- MySQL 5.7.14
- PHP 7.0.10

Précisions GLPI :
- Cache d'opcache est activé.
- plugin fusion inventory 9.1+1.1, avec client déployer partout, tout fonctionne parfaitement.
- 12 entités (monde médical, plusieurs hôpitaux etc)
- environ 200 utilisateurs pour le moment, ça augmente tous les jours
- 2220 Ordinateurs, 800 imprimantes, en augmentation.
- Environ 10 informaticiens, 4 super-admin.
- 1000 tickets crées par collecteurs mails.
- etc

Tout est parfait pour le moment. tout est fluide, tout le monde en est content jusqu’à maintenant, d'ailleurs un grand merci à toutes les personnes concernées.

Cependant, nous faisons face à un souci depuis peu.
On nous a demandé d'ajouter un champ supplémentaire dans les tickets.
On a installer le plugin "Champs supplémentaires", on a crée notre champ dans les tickets etc etc.
5 minutes (environ) après qu'on active ce plugin, GLPI devient extrêmement LENT voir impossible d'utilisation.

J'affiche les tickets sans le plugin : 0.9 seconde - 3.3 Mo
J'affiche les tickets avec le plugin : plus de 30 secondes, parfois 40 secondes, ce qui rend GLPI inutilisable.

On a cherché un peu sur le serveur GLPI, on a fait un petit script qui affiche la liste des process toutes les secondes avec la commande mysqladmin.exe pour voir ce qu'il se passe.

Sans le plugin, tout est normal et dès qu'on l'active on a ceci : 
checking permissions SELECT TABLE_NAME FROM information_schema.tables where table_schema='ma_table'
Et ca se répète des centaines de fois ...
https://www.noelshack.com/2017-12-14902 … obglpi.png
Avez-vous des idées ?

Merci.

Last edited by eric.nicolas (2017-03-23 15:32:58)

Offline

#2 2017-03-24 20:22:42

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,789

Re: Lenteur suite à l'activation du plugin "Champs supplémentaires"

Là le problème est visiblement du côté du plugin, comme vous l'avez constaté.
Il faut donc faire remonter ce problème dans la forge du plugin https://github.com/pluginsGLPI/fields/issues afin que les développeurs corrigent ce problème.


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#3 2017-03-24 22:23:36

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 3,364

Re: Lenteur suite à l'activation du plugin "Champs supplémentaires"

MySQL 5.7.14 ?

c'est pas dans les prérequis.


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+webservices PHP7.0 Mariadb10
*GLPI 9.2(behaviours1.5.2+fusion9.2+1.0+applicatifs2.3.0)hebergé sur serveur mutualisé.

Offline

Board footer

Powered by FluxBB