You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-01-23 10:03:16

techinfofao
Guest
Registered: 2017-01-23
Posts: 3

Interface vide après modif

Synology DS416J
DSM 6.0.2-8451 Update 9
glpi 9.1
PHP 5.6
MariaDB 5.5.53-0070
Apache http server 2.2

Bonjour,
Après l'installation du paquet glpi (tout se passe bien), je me connecte à l'interface avec l'utilisateur "glpi" par exemple.
Jusque là, tout va bien.
Mon problème est le suivant :
Si je modifie un paramètre (le mot de passe d'un utilisateur par exemple), une fois ce changement appliqué, l'interface est vide.
Je n'ai que les menus et plus rien d'autre.
Si je me déconnecte et que je me reconnecte, je retrouve l'interface .... jusqu'à la prochaine modif.
J'obtiens le même résultat sur différents navigateurs, et avec différents PCs.

1485157917-glpi1.jpg


Quelqu'un pourrait-il m'orienter sur la cause de ce dysfonctionnement ?
Merci.

Last edited by techinfofao (2017-01-23 10:06:24)

Offline

#2 2017-01-24 11:15:00

techinfofao
Guest
Registered: 2017-01-23
Posts: 3

Re: Interface vide après modif

Sinon, quelqu'un pourrait-t-il m'indiquer comment récupérer un package d'une version antérieure de GLPI (la 0.90.3 par exemple) pour DSM6.

Merci.

Offline

#3 2017-01-25 16:46:04

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,789

Re: Interface vide après modif

Avez-vous des erreurs dans les logs de GLPI ? dans les logs d'apache ?

Concernant les versions antérieures, il n'est pas possible de downgrader la version en cours


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#4 2017-01-26 18:08:16

techinfofao
Guest
Registered: 2017-01-23
Posts: 3

Re: Interface vide après modif

Rien de significatif dans les logs GLPI.
Pour les logs apache, je ne les trouve pas sous DSM6. Rien dans var/log/httpd

Offline

#5 2017-02-02 10:09:53

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,789

Re: Interface vide après modif

Vérifier dans votre base de données si vous n'auriez pas une table de crachée


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#6 2017-02-08 12:24:16

ALCMD
Guest
Registered: 2017-02-08
Posts: 38

Re: Interface vide après modif

Bonjour à tous,

Idem, même problème. J'ai essayer de réinstaller GLPI une seconde fois, pas mieux.
Je me suis dis que je n'allais pas supprimer install.php des fois que mais cela ne change rien.

PhpMyAdmin ne me retourne pas d'erreurs. J'ai essayé de redémarrer le NAS, pas mieux.

Merci d'avance pour votre aide smile

Amaury


Environnement :
VM Hyper V Windows Server 2012 - WampServer 3.0.6 - Apache 2.4.23 - PHP 5.6.25 - MySQL 5.7.14
GLPI :
Glpi 9.1.1 - FusionInventory 9.1+1.0 - Ressources Humaines 2.3.0 - Impression PDF 1.1

Offline

#7 2017-02-08 13:45:06

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,789

Re: Interface vide après modif

Utilisez-vous des plugins ?
Si vous, avez essayé en les désactivant ?


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#8 2017-02-08 15:03:24

ALCMD
Guest
Registered: 2017-02-08
Posts: 38

Re: Interface vide après modif

Pas du tout, il s'agit de ma 1ère install de GLPI, j'ai juste supprimé les utilisateurs et changé le mot de passe admin.

J'ai essayé avec un autre compte utilisateur dans GLPI, même chose.


Environnement :
VM Hyper V Windows Server 2012 - WampServer 3.0.6 - Apache 2.4.23 - PHP 5.6.25 - MySQL 5.7.14
GLPI :
Glpi 9.1.1 - FusionInventory 9.1+1.0 - Ressources Humaines 2.3.0 - Impression PDF 1.1

Offline

#9 2017-02-08 17:23:57

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,789

Re: Interface vide après modif

Pouvez-vous poster vos paramètres sytèmes visibles dans la config générale de GLPI ?


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#10 2017-02-08 18:39:39

ALCMD
Guest
Registered: 2017-02-08
Posts: 38

Re: Interface vide après modif

Voici la config :

Informations sur le système, l'installation et la configuration

GLPI 9.1 (/glpi => /volume1/web/glpi)

Server


Operating system: Linux NAS-INFO 3.10.77 #8451 SMP Wed Jan 4 00:30:04 CST 2017 armv7l
PHP 5.6.28 fpm-fcgi (Core, PDO, Reflection, SPL, SimpleXML, Zend OPcache, apc, apcu, cgi-fcgi, ctype, curl, date, dom, ereg,
    fileinfo, filter, gd, hash, json, libxml, mbstring, mcrypt, mhash, mysql, mysqli, mysqlnd, pcntl, pcre, pdo_mysql, readline,
    session, standard, tokenizer, xml, xmlreader, xmlwriter, zlib)
Setup: max_execution_time="600" memory_limit="128M" post_max_size="32M" safe_mode="" session.save_handler="files"
    upload_max_filesize="64M"
Software: Apache/2.2.31 (Unix) mod_fastcgi/mod_fastcgi-SNAP-0910052141 ()
    Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Server Software: Source distribution
    Server Version: 5.5.53-MariaDB
    Server SQL Mode:
    Parameters: [email protected]/glpi
    Host info: Localhost via UNIX socket
   
OK/volume1/web/glpi/config : OK
OK/volume1/web/glpi/files : OK
OK/volume1/web/glpi/files/_dumps : OK
OK/volume1/web/glpi/files/_sessions : OK
OK/volume1/web/glpi/files/_cron : OK
OK/volume1/web/glpi/files/_graphs : OK
OK/volume1/web/glpi/files/_lock : OK
OK/volume1/web/glpi/files/_plugins : OK
OK/volume1/web/glpi/files/_tmp : OK
OK/volume1/web/glpi/files/_rss : OK
OK/volume1/web/glpi/files/_uploads : OK
OK/volume1/web/glpi/files/_pictures : OK
OK/volume1/web/glpi/files/_log : OK
Web access to files directory is protectedWeb access to files directory is protected : OK

Libraries


htmLawed version 1.1.21 in (/volume1/web/glpi/lib/htmlawed)
phpCas version 1.3.4 in (/volume1/web/glpi/vendor/jasig/phpcas/source)
PHPMailer version 5.2.16 in (/volume1/web/glpi/vendor/phpmailer/phpmailer)
Zend Framework in (/volume1/web/glpi/vendor/zendframework/zend-loader/src)
zetacomponents/graph in (/volume1/web/glpi/vendor/zetacomponents/graph/src)
SimplePie version 1.4.1 in (/volume1/web/glpi/vendor/simplepie/simplepie/library)
TCPDF version 6.2.12 in (/volume1/web/glpi/vendor/tecnickcom/tcpdf)
michelf/php-markdown in (/volume1/web/glpi/vendor/michelf/php-markdown/Michelf)
true/punycode in (/volume1/web/glpi/vendor/true/punycode/src)
iacaml/autolink in (/volume1/web/glpi/vendor/iamcal/lib_autolink)
sabre/vobject in (/volume1/web/glpi/vendor/sabre/vobject/lib)
guzzlehttp/guzzle in (/volume1/web/glpi/vendor/guzzlehttp/guzzle/src)

SQL replicas


Not active

Notifications


Way of sending emails: PHP

Mails receivers

Plugins list

Par contre en explorant les autres paramètres, j'ai vu que :

Cache d'opcode de PHP
L'extension "Zend OPcache" est installée     7.0.6-devFE
Mémoire     63.99 Mio / 64 Mio   

Taux de succès     3894 / 4321   

    Zend OPcache
Redémarrage pour mémoire saturée     0        Zend OPcache
Cache données utilisateur
L'extension "APCu" est installée     4.0.7         APCu
Mémoire     402.87 Kio / 32 Mio   
1%

Taux de succès     48 / 50   
96%

Je suis pourtant sur d'avoir fait les modifs dans le Serveur Web du Syno pour augmenter cette mémoire...


Environnement :
VM Hyper V Windows Server 2012 - WampServer 3.0.6 - Apache 2.4.23 - PHP 5.6.25 - MySQL 5.7.14
GLPI :
Glpi 9.1.1 - FusionInventory 9.1+1.0 - Ressources Humaines 2.3.0 - Impression PDF 1.1

Offline

#11 2017-02-09 12:40:43

ALCMD
Guest
Registered: 2017-02-08
Posts: 38

Re: Interface vide après modif

Bonjour,

Ce matin, nouveaux tests sur un autre Synology avec DSM 5.0-4458, GLPI 0.85.4-0025 et Maria DB 5.5.47-0037, tout fonctionne !
Je vais revenir sur mon NAS avec DSM 6, supprimer tout glpi et installer une plus vieille version. Et sur le DSM 5 je vais essayer d'installer GLPI 9.1.

Je vous tient au courant !


Environnement :
VM Hyper V Windows Server 2012 - WampServer 3.0.6 - Apache 2.4.23 - PHP 5.6.25 - MySQL 5.7.14
GLPI :
Glpi 9.1.1 - FusionInventory 9.1+1.0 - Ressources Humaines 2.3.0 - Impression PDF 1.1

Offline

#12 2017-02-09 13:21:25

ALCMD
Guest
Registered: 2017-02-08
Posts: 38

Re: Interface vide après modif

Re bonjour,

Installation de la version 0.90 sur DSM 6, cela fonctionne ! Les pages ne sont pas vides.
Je vais faire toutes les maj successivement jusqu'à la dernière release stable et je vous tient au courant smile


Environnement :
VM Hyper V Windows Server 2012 - WampServer 3.0.6 - Apache 2.4.23 - PHP 5.6.25 - MySQL 5.7.14
GLPI :
Glpi 9.1.1 - FusionInventory 9.1+1.0 - Ressources Humaines 2.3.0 - Impression PDF 1.1

Offline

#13 2017-02-09 16:04:28

ALCMD
Guest
Registered: 2017-02-08
Posts: 38

Re: Interface vide après modif

J'ai passé la 0.90.1 toujours sur DSM 6, ça fonctionne.
J'ai voulu passé la 0.90.2, j'ai eu une erreur : "accès refusé" à l'install juste après avoir choisi "français". J'ai cherché un moment, j'ai essayé de passer la 0.90.3 par dessus, pas mieux.

Du coup j'ai téléchargé GLPI depuis le Centre de Paquets de Synology, j'ai refait l'install et rebelotte, bug d'affichage !
J'ai fais la MAJ vers la 9.1.1, plus de bug, ça fonctionne.
La 9.1.2 est un peu fraîche encore, je ne vais pas la passer tout de suite.

Pour résumé, si problème d'affichage avec le paquet de Synology, faire la MAJ vers la 9.1.1 smile

On peut fermer le topic je pense !

A+


Environnement :
VM Hyper V Windows Server 2012 - WampServer 3.0.6 - Apache 2.4.23 - PHP 5.6.25 - MySQL 5.7.14
GLPI :
Glpi 9.1.1 - FusionInventory 9.1+1.0 - Ressources Humaines 2.3.0 - Impression PDF 1.1

Offline

Board footer

Powered by FluxBB