1

Topic: Version PHP supporté

Bonjour a tous,
j'aimerai savoir la version de PHP supporté par GLPI ?
Merci

2

Re: Version PHP supporté

0.90.5 => de 5.4 minimum à 7.0

Mais attention certains plugins ne sont peut-être pas compatibles avec la 7..0

Dév. Fedora 25 - PHP 5.4/5.5/5.6/7.0/7.1 - MariaDB 10.1 - GLPI master
Certifié ITILv3 - RPM pour Fedora, RHEL et CentOS sur https://blog.remirepo.net/

3 (edited by kapolivier24 2016-08-05 19:04:49)

Re: Version PHP supporté

Merci,
ma version est 90.1, la réponse précédente reste valable pour elle également ?

4

Re: Version PHP supporté

90.1 ?   0.90.1 ou 9.1 (RC2) ?

Dév. Fedora 25 - PHP 5.4/5.5/5.6/7.0/7.1 - MariaDB 10.1 - GLPI master
Certifié ITILv3 - RPM pour Fedora, RHEL et CentOS sur https://blog.remirepo.net/

5

Re: Version PHP supporté

0.90.1

6

Re: Version PHP supporté

Donc aucune garantie pour une ancienne version non maintenue et PHP 7, il y a eu pas mal de correctif depuis sa sortie.

Dév. Fedora 25 - PHP 5.4/5.5/5.6/7.0/7.1 - MariaDB 10.1 - GLPI master
Certifié ITILv3 - RPM pour Fedora, RHEL et CentOS sur https://blog.remirepo.net/

7

Re: Version PHP supporté

pour ma part 0.91 avec php 7.04 tout ok

news                 Name: Alerts                         Version: 0.90-1.3   State: Enabled
    webapplications      Name: Applications Web               Version: 2.1.1      State: Enabled
    badges               Name: Badges                         Version: 2.1.1      State: Enabled
    certificates         Name: Certificats                    Version: 2.1.1      State: Enabled
    fields               Name: Champs supplémentaires         Version: 0.90-1.1   State: Enabled
    behaviors            Name: Comportements                  Version: 1.0        State: Enabled
    dashboard            Name: Dashboard                      Version: 0.7.1      State: Enabled
    escalade             Name: Escalation                     Version: 0.90-1.1   State: Enabled
    datainjection        Name: File injection                 Version: 2.4.2      State: Enabled
    formcreator          Name: Formulaires                    Version: 0.90-1.3.4 State: Enabled
    fpsoftware           Name: FP Software                    Version: 1.1.0      State: Enabled
    fusioninventory      Name: FusionInventory                Version: 0.90+1.3+TECLIB_20 State: Enabled
    pdf                  Name: Impression pdf                 Version: 1.0.2      State: Enabled
    monitoring           Name: Monitoring                     Version: 0.90+1.1   State: Not activated
    mydashboard          Name: My Dashboard                   Version: 1.2.1      State: Enabled
    reports              Name: Reports                        Version: 1.9.1      State: Enabled
    reservation          Name: Réservation                    Version: 1.3.2      State: Enabled
    webservices          Name: Services Web                   Version: 1.6.0      State: Enabled
    simcard              Name: Sim cards management           Version: 1.4.1      State: Enabled

Yannick

Prod : GLPI 9.2 - Windows 2012 R2 - IIS 8.5 - Mariadb 10.1 - PHP 7.12 - Fusion 2.3.19
Certifié ITIL V3, PMP

8

Re: Version PHP supporté

Fait attention pour "fusioninventory      Name: FusionInventory                Version: 0.90+1.3+TECLIB_20"

Ce n'est pas la version officielle et en plus il n'y a pas le fix de la faille de sécurité qui a été corrigée y a 2 semaines dans la release 0.90+1.4