You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2016-08-02 11:25:54

jterriere
Guest
From: bordeaux
Registered: 2009-02-25
Posts: 82

composer install --no-dev

Bonjour,

J'ai voulu installer la dernière version de GLPI sur mon serveur de TEST, j'ai fait comme habituellement mais j'obtiens cette erreur :

Run "composer install --no-dev" in the glpi tree

Comment résoudre ce problème sachant que je suis sur du debian.
Merci de votre aide

Offline

#2 2016-08-02 13:34:25

remi
GLPI-DEV
From: Champagne
Registered: 2007-04-28
Posts: 7,104
Website

Re: composer install --no-dev

Ben en faisant ce qu'il indique

composer install --no-dev

Par ailleurs : https://github.com/glpi-project/glpi/issues/848


Dév. Fedora 27 - PHP 5.6/7.0/7.1/7.2 - MariaDB 10.2 - GLPI master
Certifié ITILv3 - RPM pour Fedora, RHEL et CentOS sur https://blog.remirepo.net/

Offline

#3 2016-08-09 10:34:44

renzo
Guest
Registered: 2008-10-16
Posts: 29

Re: composer install --no-dev

Bonjour
Pour une debian il faut suivre ce petit procedure.

Si tu es sur Debian il te faut php5-cli

apt-get install curl php5-cli

en suite

curl -sS https://getcomposer.org/installer | sudo php -- --install-dir=/usr/local/bin --filename=composer

et en suite

Run "composer install --no-dev" in the glpi tree

Cordialement

Last edited by renzo (2016-08-09 10:35:25)

Offline

#4 2016-08-09 11:14:09

remi
GLPI-DEV
From: Champagne
Registered: 2007-04-28
Posts: 7,104
Website

Re: composer install --no-dev

Sur Fedora/RHEL/CentOS, c'est encore plus simple: "yum install composer" wink


Dév. Fedora 27 - PHP 5.6/7.0/7.1/7.2 - MariaDB 10.2 - GLPI master
Certifié ITILv3 - RPM pour Fedora, RHEL et CentOS sur https://blog.remirepo.net/

Offline

#5 2016-08-09 19:35:32

fdebouys
Guest
Registered: 2016-06-22
Posts: 49

Re: composer install --no-dev

Bonjour,

et sur Windows 10 ?

Je souhaiterai tester cette nouvelle version sur mon portable avant de l'installer sur le serveur debian de l'entreprise.

Merci.


P.S. : J'ai téléchargé Composer-Setup.exe. Mais il me demande le chemin d'un fichier php.exe... et là je ne vois pas du tout où je peux trouver ça.

Offline

#6 2016-08-10 15:45:20

fdebouys
Guest
Registered: 2016-06-22
Posts: 49

Re: composer install --no-dev

un petit up

merci

Offline

#7 2016-08-11 11:25:06

fdebouys
Guest
Registered: 2016-06-22
Posts: 49

Re: composer install --no-dev

Personne ne connait ?

Offline

#8 2016-08-11 11:30:30

ddurieux
Plugins Dev
From: Monsols, France
Registered: 2005-06-17
Posts: 7,520

Re: composer install --no-dev

aucune idée, sinon tu attends la prochaine archive qui ne soit pas incomplète tongue


Support / dev / installation / configuration GLPI : [email protected]
DCS : expert GLPI & FusionInventory / Développeur du plugin FusionInventory
IRC #glpi sur freenode.net

Offline

#9 2016-08-11 14:46:50

fdebouys
Guest
Registered: 2016-06-22
Posts: 49

Re: composer install --no-dev

ok wink

Merci quand même wink

Offline

#10 2016-12-01 11:09:42

Stryt
Guest
Registered: 2015-11-06
Posts: 5

Re: composer install --no-dev

Bonjour,

Je fais un petit up du sujet, car, j'ai exactement le même message pour migrer ma base test de 0.90.5 vers 0.91.
Run "composer install --no-dev" in the glpi tree

Je suis sous Windows Server 2008R2.

Personne n'a trouvé la solution?

EDIT: Problème résolu pour le message, l'archive ".zip" est incomplète, j'ai donc pris l'archive ".tar.gz"

Last edited by Stryt (2016-12-01 11:16:37)

Offline

#11 2016-12-01 11:15:24

ddurieux
Plugins Dev
From: Monsols, France
Registered: 2005-06-17
Posts: 7,520

Re: composer install --no-dev

t'as pris l'archive de la release 9.1.1 ?


Support / dev / installation / configuration GLPI : [email protected]
DCS : expert GLPI & FusionInventory / Développeur du plugin FusionInventory
IRC #glpi sur freenode.net

Offline

#12 2016-12-01 11:17:21

Stryt
Guest
Registered: 2015-11-06
Posts: 5

Re: composer install --no-dev

ddurieux wrote:

t'as pris l'archive de la release 9.1.1 ?

Problème résolu pour le message, l'archive ".zip" est incomplète, j'ai donc pris l'archive ".tar.gz" smile

J'avais le message avec les deux.

Last edited by Stryt (2016-12-01 11:17:44)

Offline

#13 2018-05-28 17:30:01

ChristianTiki
Guest
Registered: 2018-05-28
Posts: 2

Re: composer install --no-dev

Hello, I'm new to these glpi revisions, I have windows 2012 server and I have installed xampp and when I access the glpi folder to install it, it shows me the following error:
"
Run "composer install --no-dev" in the glpi tree.
To install composer please refer to https://getcomposer.org/
"
I downloaded the composer executable and I installed it and even so it keeps coming out, help me, I'm going crazy, thanks in advance.

Offline

#14 2018-06-13 11:58:27

verus
Guest
Registered: 2007-06-07
Posts: 52

Re: composer install --no-dev

I get this:

[[email protected] glpi]# composer install --no-dev
Do not run Composer as root/super user! See https://getcomposer.org/root for details
Loading composer repositories with package information
Installing dependencies from lock file
Nothing to install or update
Generating optimized autoload files
Warning: Ambiguous class resolution, "Zend\Cache\PatternPluginManager\PatternPluginManagerV2Polyfill" was found in both "/var/www/html/glpi/vendor/zendframework/zend-cache/src/PatternPluginManager/PatternPluginManagerV2Polyfill.php" and "/var/www/html/glpi/vendor/zendframework/zend-cache/src/PatternPluginManager.php", the first will be used.
> @php -r "file_put_contents('.composer.hash', sha1_file('composer.lock'));"
> patch -d vendor/zendframework/zend-cache/ -p1 < tools/zend-cache-php7.2.patch
The next patch would create the file autoload/patternPluginManagerPolyfill.php,
which already exists!  Assume -R? [n]
Apply anyway? [n]
Skipping patch.
1 out of 1 hunk ignored
The next patch would create the file src/PatternPluginManager/PatternPluginManagerTrait.php,
which already exists!  Assume -R? [n]
Apply anyway? [n]
Skipping patch.
1 out of 1 hunk ignored
patching file src/PatternPluginManager.php
Reversed (or previously applied) patch detected!  Assume -R? [n]
Apply anyway? [n]
Skipping patch.
4 out of 4 hunks ignored -- saving rejects to file src/PatternPluginManager.php.rej
The next patch would create the file src/PatternPluginManager/PatternPluginManagerV3Polyfill.php,
which already exists!  Assume -R? [n]
Apply anyway? [n]
Skipping patch.
1 out of 1 hunk ignored
Script patch -d vendor/zendframework/zend-cache/ -p1 < tools/zend-cache-php7.2.patch handling the post-install-cmd event returned with error code 1

Offline

Board footer

Powered by FluxBB